[scribus] Cannot run the Fedora 29 version or the AppImage

Doug Hutcheson owlbrudder at gmail.com
Wed Dec 5 21:52:04 UTC 2018

On Thu, 2018-12-06 at 05:49 +1000, Doug Hutcheson wrote:
> It doesn?t look like a Scribus related build issue. Podofo and
> fontconfig? Is fontconfig properly installed?
> Craig
> Thanks for the idea Craig. I tried 'dnf install fontconfig', but it
> does seem to be installed OK.
> Package fontconfig-2.13.1-3.fc29.x86_64 is already installed.
> Package fontconfig-2.13.1-3.fc29.i686 is already installed.
> Dependencies resolved.
> Nothing to do.
> Complete!
> [doug at womble build]$ 
> I tried 'dnf reinstall fontconfig' then 'make', but make failed at
> the link stage again.
> I will keep bashing away, but would appreciate any further clues the
> list could come up with.
> Kind regards, Doug.

I found a similar issue reported at this page. The solution was
reported as follows. Could this (modified for Scribus obviously) be at
the root of my problem as well?:

Okay, thanks to @Tsyvarev , found the problem.
It lies within the linking order which is specified
in CMakeLists.txt file. It should have the following order, in which -
lpthread comes before libapr-1.a

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.scribus.net/pipermail/scribus/attachments/20181206/f4d0311f/attachment.html>

More information about the scribus mailing list