[scribus] Cannot run the Fedora 29 version or the AppImage

Gregory Pittman gpittman at iglou.com
Wed Dec 5 20:56:14 UTC 2018

On 12/5/18 2:49 PM, Doug Hutcheson wrote:
> It doesn?t look like a Scribus related build issue. Podofo and
> fontconfig? Is fontconfig properly installed?
> Craig
> Thanks for the idea Craig. I tried 'dnf install fontconfig', but it
> does seem to be installed OK.
> Package fontconfig-2.13.1-3.fc29.x86_64 is already installed.
> Package fontconfig-2.13.1-3.fc29.i686 is already installed.
> Dependencies resolved.
> Nothing to do.
> Complete!
> [doug at womble build]$ 
> I tried 'dnf reinstall fontconfig' then 'make', but make failed at the
> link stage again.
> I will keep bashing away, but would appreciate any further clues the
> list could come up with.

Make sure you have fontconfig-devel.

Here is a command I use on Fedora:

sudo dnf -y install boost-devel cairo-devel cups-devel fontconfig-devel freetype-devel GraphicsMagick-c++-devel GraphicsMagick-devel harfbuzz-devel hunspell-devel kernel-devel lcms2-devel libicu-devel libjpeg-turbo-devel libmspub-devel libpng-devel librevenge-devel libstdc++-devel libtiff-devel libwpd-devel libxml2-devel OpenSceneGraph-devel podofo-devel poppler-devel poppler-data poppler-data-devel poppler-cpp poppler-cpp-devel python-devel python-qt5-devel qt5-qtbase-devel qt5-qtdeclarative-devel qt5-qttools-devel qt5-qtwebkit-devel

to make sure I have everything I need.


More information about the scribus mailing list