[scribus] Scannig problem

John Culleton john at wexfordpress.com
Fri Oct 1 01:15:01 CEST 2010

On Thursday 30 September 2010 09:38:41 Ray wrote:
> Thanks for your reply Frank - BUT, as I said, my scanner is not
> recognised - in Ubuntu or in Mint - no lights, no noise, it's not
> recognised. Logging out of either and back into Windows and it
> works fine. Xsane says there is no scanner connected. I can print
> OK, but not scan!
> Ray
> ------------------------------
> Hi All,
> In DTP (with a Windows program) in the past, I have been used to
> scanning photos, repairing them, and then placing into a Newsletter
> page. Using Scribus and/or 1.3.5 in Ubuntu 10.04, my Canon
> scanner is unrecognised.
> What is the work around for this - if any?
> Ray
> ------------------------------
> Message: 7
> Date: Thu, 30 Sep 2010 01:05:25 -0600
> From: Frank Cox <melville.theatre at gmail.com>
> Subject: Re: [scribus] Scanning pics
> To: Scribus User Mailing List <scribus at lists.scribus.net>
> Message-ID: <1285830325.5890.111.camel at mutt.melvilletheatre.net>
> Content-Type: text/plain
> On Thu, 2010-09-30 at 16:22 +0930, Ray wrote:
> > What is the work around for this - if any?
> Gimp has an "Acquire Image" menu option.  Scan your image into Gimp
> and save it, then place it on your Scribus page.

I haven't used my scanner for a while. So I need to go through the 
setup steps on my newest partition. 

Old fogies like me use Slackware Linux and Xsane as the scanning 
program. When I fire up Slack the following text appears:
usb 2-1: new full speed USB device using uhci_hcd and address 4
usb 2-1: New USB device found, idVendor=04b8, idProduct=010b
usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-1: Product: Perfection1240
usb 2-1: Manufacturer: EPSON
usb 2-1: configuration #1 chosen from 1 choice
scsi 5:0:0:0: Direct-Access     ST325082 4A               3.AA PQ: 0 
The command to view the messages from boot time is

So far so good. The system found the scanner.
Next as root I look in /etc/sane.d
for something named epson. I find epson.conf
I go into that file and uncomment the line that says

Next I look in /dev for all the usb devices with the command
ls -l *usb* |less
everything belongs to root and group root except this line:
crw-rw-r-- 1 root scanner 189, 131 2010-09-30 11:36 usbdev2.4

This guy belongs to group scanner. That means that users who are part 
of group scanner can use it.  Back to /etc/group. It turns out that my 
user name doesn't belong to group scanner. I edit file group to change 
the scanner line to include my user name. It now reads something like
(assuming of course that my user name is xyz).

Now I try to fire up xsane from my user gui. Scanner not found. Bummer!
Reboot, Now it works. I can make xsane work from a terminal on my gui
or from a menu selection, whether I sign on as root or as "xyz".

On my system I also have a utility scanlite. It works too. 

 Gimp for some reason doesn't have an acquire option (it used to.) 
First find the gimp plug in directory:
Then go to that directory and link xsane:
ln /usr/bin/xsane .
note the (space) period. It is not optional! That is the target addy. 

Still no workee. Sign off as user xyz and sign on again. Now the 
scanner appears under the file->create->acquire submenu. 

What about Scribus? Well it doesn't have a link to the scanner yet. 
Maybe someday. In the meantime there is Gimp, or just plain xsane.

John Culleton
Wexford Press
"Create Book Covers with Scribus"
Printable E-book 38 pages $5.95

John Culleton
Wexford Press
"Create Book Covers with Scribus"
Printable E-book 38 pages $5.95

More information about the scribus mailing list