[scribus] Formula in 1.3.5 (bug)

John Jason Jordan johnxj at comcast.net
Wed Apr 8 00:04:18 CEST 2009

On Tue, 7 Apr 2009 21:02:19 +0200
alessandro rimoldi <ale.comp_06 at xox.ch> dijo:

> > If the embed pdf feature is in this version, where is the button?
> > 
> > If not, is there a way to install the version that has it on Intrepid
> > x86_64?
> there should be a checkbox in the main tab of your "pdf export" dialog...
> ... if it's not there, you're out of luck and:

Oh, sorry there has been a major misunderstanding. 

I thought "embed PDF" meant to *import* a PDF as a vector and embed it
in the document rather than link it. I didn't realize it was for
*exporting* as PDF.

My problem is that I am trying to get formulas out of LyX because I
need them set with a specific font. That means I need to use XeTeX.
Unfortunately, XeTeX does not understand PostScript. So I have to
export from LyX as PDF. That works OK, but Scribus can't place the PDF
without rasterizing it.

I tried pdf2ps and it worked fine, but it converted the PDF to a bitmap
PS file. Scribus was happy to place the PS file, but it is really bad.
No gain.

There is only one way I can get the formula out of LyX and have the
special font included, and that is PDF. At least, as far as I know that
is true.

I can copy the code from LyX and put it into a TeX formula in Scribus,
and that works fine, too. Except that it is also a bitmap, prints bad,
and I can't use the font I need.

My work requires hundreds of formulas per document, so I need something
relatively quick and easy that also gets me good output. If anyone has
any other suggestions, please speak up!

More information about the scribus mailing list