[scribus] no odt support???

Rolf-Werner Eilert eilert-sprachen at t-online.de
Fri Jun 27 08:33:44 CEST 2008

John Culleton schrieb:
> On Thursday 26 June 2008 05:06:45 pm Craig Bradney wrote:
>>> The wiki tends to bury a leaf in a forest, with all kinds of
>>> strategies which the end user has no need of. Indeed the whole
>>> cmake process fixes problems that I don't have. For all my app
>>> software I put each new version in its own directory. Then I
>>> compile it. The older executable is renamed. The newer one is
>>> copied
>>> to /usr/local/bin. Right now I have in that /usr/local/bin:
>>> scribus (
>>> and
>>> scribus11 (
>>> Both work now.
>> You cant just do that and expect it to work.. the plugins are built
>> for a particular version.. copying just the executable wont work
>> properly, plus the executable has the paths you set with configure
>> or cmake for plugins stored in it.. use make install, not copy
>> (unless you copy the whole tree to the install location which is
>> rediculous).
>>> The directory "local" means just what it says. Software that
>>> comes with Linux is in /usr/bin. Software that I install resides
>>> in /usr/local/bin.  That is where you will find executables for
>>> Scribus, Gimp, Inkscape, two flavors of COBOL and so on. It is on
>>> the search path for everyone. Going down a third level to
>>> /home/whatever is overkill for a single user machine.  Suppose I
>>> sign on as root?
>> Why would you want to run Scribus or Gimp or Inkscape etc as root?
>>> Then the Scribus program becomes invisible.
>> Thats part of the idea. You dont want to run any of these apps as
>> root, unless of course you want to run under the Windows
>> philosophy.
>> Craig
> And if for some reason I create another user id (for a grndchild 
> perhaps) then Scribus is similarly walled off. Other software is 
> available to all users, why not Scribus? For example TeX is 
> in /usr/local/texlive by default, and the binary there is in the 
> search path defined by /etc/profile. 
> I ran make install, but the old defective vesion of was still 
> in the /usr/local bin directory.  Possibly it was an ownership 
> problem. l So I deleted it and copied the correct one there. 
> Remember /usr/local/bin is searched ahead of e.g., /usr/bin.  So 
> anyhow it works.  No error messages. 
> I'll have to see if the improvements in handling text have an effect 
> on my jobs.  Tomorrow---

On my system, I found 3 places with scribus:

server03:/ # whereis scribus
scribus: /usr/local/bin/scribus /usr/local/lib/scribus

and then there is


Anything wrong with that? It's now.

I tried cmake yesterday, and my first impression was "much faster", then 
I saw that there are different colors for the compiler output :-)

After compiling I found the binary in the compile directory (due to "." 
I guess). Anyway, it worked a bit afterwards, but that Scribus had no 
icons and didn't know about any text reading plugins.

Any suggestions what exactly I should do to make the new 
running flawlessly?


More information about the scribus mailing list