[Scribus] has an unresolvable dependency in Ubuntu Edgy

Oleksandr Moskalenko malex
Tue Nov 14 01:12:04 CET 2006

* Michael Koren <kung42o at mindspring.com> [2006-11-13 14:40:47 -0800]:

> Julian Robbins wrote:
> > 
> > Hi
> > 
> > When I tried to install from Alex's Ubuntu repository on my 
> > freshly installed Ubuntu 6.10, Edgy Eft I came up against this .
> > 
> > 'Unresolvable dependency on libcupsys2-gnutls10>= 1.1.23-1'
> > 
> > Now I have already got libcupsys2 version 1.2.4-2 and the other libcup 
> > dev packages, so I'm thinking that possibly Ubuntu Edgy has a name 
> > change on this package ? This is only a guess.
> > 
> > Either way, I cant install which I want to do.
> > 
> > Any ideas?
> > 
> > Julian Robbins
> > 
> Hi Julian,
> Which repository did you use? I think only the breezy repository has that
> dependency; the ones for dapper and debian etch use the newer package name
> libcupsys2, as you guessed. I just tested all three packages myself for a
> different reason, so I came across that too. (Although in debian there's a
> dependancy package libcupsys2-gnutls10 that depends on libcupsys2, and
> installing that lets you install packages depending on the old name.)
> I ran into a different dependency problem with the dapper and etch packages
> though, namely they depend on older versions of libgnutls (11 and 12) which
> aren't in etch and probably aren't in edgy either, so I don't know if you
> could install those either. (I think it's a mistake, as the breezy package
> doesn't depend on gnutls at all.) I emailed Alex privately about it the
> other day already.
> In the mean time, if the dapper package doesn't work, I would suggest you
> check if there's a libcupsys2-gnutls10 dependency package in edgy and keep
> using the scribus package for breezy. If there's not such a package in edgy,
> you could download the one from debian testing, or just force the scribus
> package installation without it, as your libcupsys2 provides the same
> contents anyway.
> Hope that helps,
> Michael

I think my Ubuntu chroots could contain obsolete packages if those did not get
automatically updated. The chroots are up-to-date, but it could still be a
problem as I ran into this with Debian unstable where I had libgnutls11
locally, but libgnutls13 in the pbuilder. Since 13 is not an upgrade but a
different tree it wasn't updated and a locally built package would depend on
11 while a package built with pbuilder would depend on libgnutls13.

Anyway, I think it's a chroot problem on my side. I should delete and rebuild
all my chroots or go through all scribus dependencies, direct and indirect,
and upgrade them one by one to alleviate this problem. Or I should completely
switch to pbuilder.


More information about the scribus mailing list