[Scribus] has an unresolvable dependency in Ubuntu Edgy

Michael Koren kung42o
Mon Nov 13 23:40:47 CET 2006

Julian Robbins wrote:
> Hi
> When I tried to install from Alex's Ubuntu repository on my 
> freshly installed Ubuntu 6.10, Edgy Eft I came up against this .
> 'Unresolvable dependency on libcupsys2-gnutls10>= 1.1.23-1'
> Now I have already got libcupsys2 version 1.2.4-2 and the other libcup 
> dev packages, so I'm thinking that possibly Ubuntu Edgy has a name 
> change on this package ? This is only a guess.
> Either way, I cant install which I want to do.
> Any ideas?
> Julian Robbins

Hi Julian,

Which repository did you use? I think only the breezy repository has that
dependency; the ones for dapper and debian etch use the newer package name
libcupsys2, as you guessed. I just tested all three packages myself for a
different reason, so I came across that too. (Although in debian there's a
dependancy package libcupsys2-gnutls10 that depends on libcupsys2, and
installing that lets you install packages depending on the old name.)

I ran into a different dependency problem with the dapper and etch packages
though, namely they depend on older versions of libgnutls (11 and 12) which
aren't in etch and probably aren't in edgy either, so I don't know if you
could install those either. (I think it's a mistake, as the breezy package
doesn't depend on gnutls at all.) I emailed Alex privately about it the
other day already.

In the mean time, if the dapper package doesn't work, I would suggest you
check if there's a libcupsys2-gnutls10 dependency package in edgy and keep
using the scribus package for breezy. If there's not such a package in edgy,
you could download the one from debian testing, or just force the scribus
package installation without it, as your libcupsys2 provides the same
contents anyway.

Hope that helps,

View this message in context: http://www.nabble.com/-Scribus--
Sent from the Scribus mailing list archive at Nabble.com.

More information about the scribus mailing list