[Scribus] Scribus 1.3.3 on Ubuntu Dapper, AMD 64, crashes on text import

Axel Bojer axelb
Sat Aug 26 09:57:53 CEST 2006

Gregory Pittman skrev:
> Axel Bojer wrote:
>> Gregory Pittman skrev:
>>> Axel Bojer wrote:
>>>> 1. I mark my textframe and ...
>>>> 2. Go to ?File - import - get Text? and find my odt-file. Then ...
>>>> 3. I get a dialog with the question: Choose a conversion filter
>>>> So far nothing wrong, but, wait! The box is empty! I can not choose a 
>>>> single fileformat, because no matter if I try to use the dropdown tool, 
>>>> it still shows nothing. If I just close my eyes and press ?Ok?, hoping 
>>>> Scribus will know what to do, then the program chrashes with the 
>>>> following remark to me:
>>>> 4. Scribus is crashing because of signal #11.
>>>> I suppose that something is just wrong with the linking between scribus, 
>>>> openoffice and the file properties, but I dont know how to correct this :-(
>>> You may need to build your Scribus, considering your hardware.
>>> See:
>>> http://www.scribus.net/index.php?name=Sections&req=viewarticle&artid=4&page=1
>>> Greg
>> Do you mean this repository:?
>>   # debian.scribus.net - Primary repository
>>   deb http://debian.scribus.net/debian/ hoary main restricted
>>   deb-src http://debian.scribus.net/debian/ hoary main restricted
>>   # debian.tagancha.org - Backup repository
>>   deb http://debian.tagancha.org/debian/ hoary main restricted
>>   deb-src http://debian.tagancha.org/debian/ hoary main restricted
>> or do you mean to use the tar-ball?
>> I have tried both :-(
>> The repository does not contain any packages for amd 64 (could someone 
>> correct this please? :-)
>> thats the reason why i used http://ubuntu.moshen.de. (scribus 1.3.3)
> I'm talking about building from source, available as a tar.bz2 file. I 
> looked around, and I couldn't find pre-compiled 64-bit Scribus for Ubuntu.

Oh yes, I found *two* :-)
Unofficial sources, though
I used http://ubuntu.moshen.de
but I also found http://www.janvitus.netsons.org
The last one is said to have a somewhat unstable connection though:

>> When I tried to build the tarballs myself, I got a lot of dependency 
>> problems ...
>>  From BUILDING:
>> Requirements:
>>          Qt >= 3.3 (3.3.3 recommended)
>>          Freetype >= 2.1.3 (2.1.9+ recommended)
>>          libart >= 2.3.8+ (2.3.17+ recommended)
>> ... and for the libarts I have som problems: (./configure gives)
>> configure: error: You need at least libart 2.3.8 . See the BUILDING file.
>> apt-cache show libart2 -> Version: 1.4.2-30
>> (By the way: apt-cache show freetype2 -> 1.4pre.20030402-1.1ubuntu1, but 
>> the build did not complain about that ... and how to I check my 
>> qt-version? slocate shows both qt4 and qt3 libraries, I suppose I have 
>> both then?)
> One thing that's not necessarily apparent is that many of the 
> requirements really want you to have not just the compiled libart, but 
> also the includes, the various header files. With Fedora Core, these are 
> typically a separate download, so in addition to libart... you would 
> also need libart-devel. When you try to configure, your feedback 
> unfortunately doesn't tell you that. So with qt you also want the header 
> files from qt, however they're labelled in Ubuntu.

Thank you veru much, that did it :-)
apt-get install libart-devel
(and then ./configure, make and make install)
And the build-version *does* luckily open my odt-file withoyt the 
mentioned bug :-D
I dont know why the packages from moshen.de did not work though :-(
Perhaps I ought to send him a note about this ...

What confused me for a second by the new installed package is 
that the executable file is in /usr/local/bin/scribus
As I also have /usr/bin/scribus this is a bit unfortunate. Of course I 
can fix this reference manually, but I think this should be managed by 
the install script, perhaps to /usr/local/bin/scribus-ng
(because when i now run scribus from the commandline it gives me 2.4.1, 
the standard ubuntu-package. And I have to give the whole path 
/usr/local/bin/scribus to run the new version). This is of course a 
small problem, but ...

> Once you crank through that, you're good to go.
>> By the way: I supposed that what I would get from the tarball is the 
>> same as the package from moshen.de ?
> Not sure about that. Current released version from Scribus is

After downloading and using that package: yes, it is
This is also stated here: http://ubuntu.moshen.de/dists/dapper/misc/

Best regards
Axel Bojer

More information about the scribus mailing list