[Scribus] Compile error 1.2.1 on Ubuntu

Jozsef Mak j_mak3
Tue Jan 11 05:10:57 CET 2005

>From: Craig Ringer <craig at postnewspapers.com.au>
>To: Jozsef Mak <j_mak3 at hotmail.com>
>CC: scribus at nashi.altmuehlnet.de
>Subject: Re: [Scribus] Compile error 1.2.1 on Ubuntu
>Date: Tue, 11 Jan 2005 10:29:09 +0800
>On Sun, 2005-01-09 at 15:51 -0500, Jozsef Mak wrote:
> > So far ive installed the following packages.
> >
> > libqt3-mt-dev
> > libqt3-headers
> > libqt3-compat-headers
> > libqt3c102
> > libqt3c102-mt
> >
> > I don't know what else can i do.
>I just ran into the same problem on Debian Sarge. libqt-mt.so.3 was
>in /usr/lib, the includes were in /usr/include/qt3, but it just wasn't
>finding the library. The configure snippet was compiling correctly and
>it was finding the includes. However, ld was failing because it couldn't
>find qt-mt despite it being very plainly on the default search path AND
>explicitly specified on the gcc command line.
>I had libqt3c102-mt and libqt3-dev installed.
>For some reason, installing libqt3-mt-dev instead (I still don't
>understand why they're different packages given that threading is a
>compile time option) solved the problem for me.
>Can I get you to post a snippet from config.log where it fails? Search
>for 'qt-mt' and look for the failure around there.

This is a snippet from config.log file that i could find relating to qt-mt 

configure:39606: $? = 0
configure:39609: test -s conftest
configure:39612: $? = 0
configure:39631: result: -ljpeg
configure: 39658: ${prefix}/include/jpeglib.h
configure: 39658: /usr/include/jpeglib.h
taking that
configure:39702: checking for perl
configure:39762: result: /usr/bin/perl
configure:39898: checking for Qt
configure: 39966: /usr/lib/qt3/include/qstyle.h
configure: 39966: /usr/lib/qt3/qstyle.h
configure: 39966: /usr/lib/qt/include/qstyle.h
configure: 39966: /usr/lib/qt/qstyle.h
configure: 39966: /usr/share/qt3/include/qstyle.h
taking that
tried NO
tried /usr/lib/qt3/lib
tried /usr/lib/qt3
tried /usr/lib/qt/lib
tried /usr/lib/qt
configure:40081: rm -rf SunWS_cache; g++ -o conftest -Wnon-virtual-dtor 
-Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align 
-Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -O2 
-Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new 
-fno-common -I/usr/share/qt3/include -I/usr/X11R6/include  
-DQT_THREAD_SUPPORT  -D_REENTRANT  -L/usr/share/qt3/lib -L/usr/X11R6/lib   
conftest.cc -lnsl  -lqt-mt -lpng -lz -lm -ljpeg -ldl  -lXext -lX11 -lSM 
-lICE  -lpthread 1>&5
conftest.cc:8:2: #error 1
configure:40084: $? = 1
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qcursor.h>
#include <qstylefactory.h>
#include <private/qucomextra_p.h>
#if ! (QT_VERSION >= 0x030300)
#error 1

int main() {
    QCursor c(Qt::WhatsThisCursor);
    return 0;
configure:40124: error: Qt (>= Qt 3.3) (library qt-mt) not found. Please 
check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

More information about the scribus mailing list