[Scribus] Subset all fonts doesn't work for any font!

Suki Venkat, [TnQ] skvenkat
Mon Apr 4 08:02:58 CEST 2005


I installed 1.2.1 rpm on Fedora Core 3 to test Open-Office import.
It worked fine (except for complicated files with lot of character
styles on which it made the system hang). First thing I noticed was that
it either hyphenated the whole file or not. The other funny thing I
noticed was even if you (rugged) left-justify the text or center it, it
still hyphenates it. I thought you hyphenate a text only if you justify
it (correct me if I am wrong). The next thing I noticed was there were
no ligatures (the usual "fi" "fl" etc.) even on a "Times" or "Times New
Roman" font. Then I had to go back to my openoffice file, modify the
ligatures and re-import the file into scribus. Now it works fine!
I made a PDF from the imported test.sxw file. I ticked the "Subset all
fonts" and opened it in Acrobat Reader 7.0. It shows no fonts as being
subsetted. I tick "Embed all fonts" it still shows no fonts in PDF. Now
I login as root and tick "Embed all fonts" and there I have all the
fonts embedded in my PDF. I try now the "Subset all fonts" as root (with
other fonts as well) and it still doesn't work. Even if I tick "Subset"
in Settings->Fonts->Available Fonts it still doesn't work (I suppose
this is for postscript output). Please help.


TnQ Books and Journals, Chennai

More information about the scribus mailing list