[Scribus] Subset all fonts doesn't work for any font!

Craig Bradney cbradney
Mon Apr 4 08:13:33 CEST 2005

On Monday 04 April 2005 08:02, Suki Venkat, [TnQ] wrote:
> Hi,
> I installed 1.2.1 rpm on Fedora Core 3 to test Open-Office import.
> It worked fine (except for complicated files with lot of character
> styles on which it made the system hang). First thing I noticed was that
> it either hyphenated the whole file or not. The other funny thing I
> noticed was even if you (rugged) left-justify the text or center it, it
> still hyphenates it. I thought you hyphenate a text only if you justify
> it (correct me if I am wrong).

Scribus 1.2.x hyphenates the whole text of a linked frame set and stores it so 
as to use it on systems that dont have all the hyphenation dictionaries. 1.3 
will do this differently.

> The next thing I noticed was there were 
> no ligatures (the usual "fi" "fl" etc.) even on a "Times" or "Times New
> Roman" font. Then I had to go back to my openoffice file, modify the
> ligatures and re-import the file into scribus. Now it works fine!

Scribus supports inserting unicode chars but not auto replacement of 
ligatures, not yet anyway.

> I made a PDF from the imported test.sxw file. I ticked the "Subset all
> fonts" and opened it in Acrobat Reader 7.0. It shows no fonts as being
> subsetted. I tick "Embed all fonts" it still shows no fonts in PDF. Now
> I login as root and tick "Embed all fonts" and there I have all the
> fonts embedded in my PDF. I try now the "Subset all fonts" as root (with
> other fonts as well) and it still doesn't work. Even if I tick "Subset"
> in Settings->Fonts->Available Fonts it still doesn't work (I suppose
> this is for postscript output). Please help.

Embedding works. Subsetting converts to outlines at this point in time. The 
root/user issue is a local permissions one I assume as there no permissions 
checked in Scribus other than what the filesystem provides.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://nashi.altmuehlnet.de/pipermail/scribus/attachments/20050404/718503ab/attachment.pgp 

More information about the scribus mailing list