[Scribus] Simple question on woody installation
Mon Aug 9 04:23:27 CEST 2004
> Haines Brown wrote:
> > I'd like to install scribus 1.1.7 on woody, and have followed the
> > directions concerning sources.list and pinning that are found on the
> > scribus web site. When I run apt-get install scribus, I (naturally)
> > get a long list of unsatisfied dependencies. I have an elementary
> > question on the interpretation of this list..
> > For example,
> > scribus: Depends: libart-2.0-2 (>= 2.3.16) but 2.3.8-1 is to be
> > installed
> Try "apt-get install libart-2.0/unstable libart-2.0-dev/unstable".
> > What is meant by, "is to be installed"? Did it fail simply because it
> > depended on another package that is not installed?
> I think "is to be installed" means something like "would be installed if
> we kept on doing what we're not going to do." Very intuitive.
Thanks, Steve, your advice much appreciated, but it carried this
simpleton only so far ;-(.
1. So the libart-2.0.2 is all I need. But then what do the
references mean to 2.3.16 and 2.3.8-1? If it wanted to install
2.0-2 to satisfy the dependency, why mention them?
2. When I went to install libart-2.0/unstable, it turns out to have an
libc6 >=2.3.2.ds1-4, but 2.2.5-11.5 is to be installed.
I believe the libc6_2.2.5-11.5 is what I'm running, and the
2.3.2.ds1-4 is what is needed to satisfy libart's dependency. But I
get the impression doing a libc6 upgrade will break all sorts of
applications and should be avoided at all cost. Is this warning
exaggerated? If I do get into trouble, is there an easy way to back
out (keep a backup of the older libc6)?
More information about the scribus