[scribus] Embedding fonts in a PDF file

Michael Holmes mh.holmes at verizon.net
Fri Feb 19 17:12:02 UTC 2016

On 2/19/16 3:35 AM, "Christoph Schäfer" wrote:
>> On 2/17/16 1:27 AM, Peter Nermander wrote:
>>>> As for your problem: Did you make sure that there were no other font
>>>> options like Subsettting activated by default in the font section of the
>>>> Prefs/Doc Setup? If so, that seems to be an issue on Mac OS X, because I
>>>> tried on Windows 7 and several Linux distros, all of which worked as
>>>> expected.
>>> On Windows 7 I have always had to click the [Embed all] button in the PDF
>>> export dialog to make sure all fonts are embedded. Every time I export to
>>> PDF.
>>> /Peter
>> Hi Christoph,
>> Thanks for telling me about the list's email convention, I did not know
>> that.
>> To answer your question: the fonts used in my document are Arial Bold,
>> Arial Bold Italic, Arial Regular and Book Antiqua Bold Italic.  In the
>> Fonts pane of Preferences, "Embed" is checked for all the fonts, and
>> "Subset" is checked for the Arial fonts but not for the Book Antiqua.
>> It's Book Antiqua that isn't displaying properly on other systems.  I'll
>> try checking "Subset" on that one and see what happens.  I have to admit
>> that I don't know what it means to "subset" a font.
>> If you've been following this thread, you will have seen an email from
>> Peter Nermander who sees this problem under Windows 7, and one from
>> Geoffrey Dow who sees it under Linux.  So it's not just me, and it's not
>> just OSX.  I don't know why you don't see it in your environment.
>> How do you check to see that the file is created properly?  I don't have
>> any way to examine a PDF file to see whether the fonts are embedded.  I
>> can only test by trying to view the file on a system that doesn't have
>> all of the fonts installed.  I have a Bootcamp partition on my iMac that
>> has Windows 7 installed.  I have to reboot into Windows and view the
>> file there to see if it worked properly. If I view the file under OSX
>> using Preview, it looks fine because all of the fonts are present on my
>> my iMac.  (You probably understand all of this already, I'm just putting
>> it out there.)
>> Thanks for taking the time to look into this issue!
>> Michael
> Hi Michael,
> Would you mind uploading the version of Book Antiqua you're using to the Scribus bugtracker and marking the report as "private"?
> Your particular issue might be something that can be fixed in 1.4.7, too, but our wizards will have to take a closer look into the font file(s).
> Thanks,
> Christoph

OK, I submitted it.  The bug ID is 0013762.  I included the Book Antiqua 
font file, as well as my .sla file and the exported PDF file.



More information about the scribus mailing list