[scribus] embedding fonts in pdf fails with Windows 8

"Christoph Schäfer" christoph-schaefer at gmx.de
Tue Dec 3 06:22:14 UTC 2013

> Gesendet: Montag, 02. Dezember 2013 um 20:11 Uhr
> Von: "Andreas Winkler" <and.win82 at gmail.com>
> An: scribus at lists.scribus.net
> Betreff: [scribus] embedding fonts in pdf fails with Windows 8
> Hi,
> I'm a new user of Scribus and I'm quite impressed by its capabilities
> so far. I plan to move away from Indesign.
> I run Scribus 1.4.3 on Windows 8.1 64 bit. It seems not to be possible
> to embed certain system fonts into pdf when exporting, regardless
> whether 'subset' is checked or not. The affected fonts are those which
> appear grouped in the Windows Explorer in C:\Windows\Fonts (for
> example Arial or Times New Roman), for all other fonts embedding works
> as expected.
> I've tried to export the same sla file with Scribus 1.4.3 running on
> Windows 7 and there it was possible to embed all fonts as expected. So
> I think that this issue is related to Windows 8. I'd be interested in
> whether this is a known issue and whether there exists a workaround
> (except for changing the OS :-)). Has anybody else experienced this
> problem when running Scribus on Windows 8?

Hi Andreas,

You cannot embed certain fonts because embedding is disabled by default due to their size (modern TTF and OTF font files can be quite huge). Instead, Scribus will convert these fonts to outlines. You can, however, override the default settings.

Go to File -> Document Setup -> Fonts for the current document or to File -> Preferences -> Fonts for every new file. There you can uncheck the fonts marked for "Subset" in the respective column. Unchecking means they can be embedded now, but be aware that exported PDF files can become *really* huge.



More information about the scribus mailing list