[scribus] Resize pointer elusive

Barry McKenna bmcken at pobox.com
Fri Jun 24 21:53:47 UTC 2011

On 6/24/2011 9:51 AM, Gregory Pittman wrote:
> On 06/24/2011 11:43 AM, a.l.e wrote:
>> hi tom,
>>> I have to try numerous times and "sneak up" on the image
>>> or text
>>> frame pull point to activate the resize mode of my mouse.
>>> Used on the
>>> image frame it keeps switching to the select arrow or the
>>> move hand.
>>> In text boxes it jumps from resize to move, and often
>>> moves the text
>>> block unintentionally. I don't have this problem when I
>>> use the
>>> function in other programs. I searched for this problem
>>> in the
>>> Scribus Wiki, but I'm sure I'm not using the right
>>> terminology to get
>>> results. I'm using 1.4.Orc5 on Windows Vista, but this
>>> problem
>>> occurred for me using all the versions for the last three
>>> years and
>>> when I used Win ME. Any ideas? Thank you. --------------
>>> next part
>> works correctly (well, not perfect, but correct...) here
>> on debian...
>> i wonder if it's a windows problem (other may be able to
>> confirm this) or if you're doing something not 100%
>> correctly...
> We've seen an issue with the cursor not changing when one
> wants to resize a dialog or even Properties. I just tried
> this out with on XP and saw no problem with frames,
> as long as they were selected.
> Not sure what this "sneak up" is supposed to suggest. My
> recommendation would be to never sneak up on a Scribus
> frame, you know, they have feelings too. Do you like someone
> sneaking up on you in the shower, poking you with a cursor
> as if your some piece of beef on a barbecue grill? I think not.

I posted a comment about this type of behavior in Mantis 
some months back, perhaps for v1.3.8.

I'm currently still using 1.3.9, and have not upgraded 
because my needs from Scribus a fairly minimal, for the time 

I can definitely identify with the need to "sneak up" on the 
frame's border, trying to get the cursor to change to the 
sizing arrow. It takes a sustained effort with a lot of 
sneaking and jiggling to get the cursor to change to the 
sizing arrow. This behavior is not constant, but about 50% 
of the time. I also see that the bottom half of the cursor 
disappears when I'm moving over a frame.

For the time being, this issue has been a minor one for me, 
only because most of my Scribus work for now involves 
importing SVG files, so there's no need for frames, except 
when I have to add text. But I suspect that when I need to 
start importing eps files again - unless I'm able to rewrite 
my export code and produce those normally in eps into SVG, 
but I don't know about that because I'll need to use Unicode 
Private Use Arear glyphs, and I haven't tried to resolve 
that output issue with SVG yet.

I had not made an issue out of this, other than filing a 
report to Mantis. I presumed - apparently incorrectly - that 
this cursor issue was likely due to my still using Win2000/sp4.

Barry McKenna

More information about the scribus mailing list