[scribus] Idiot wants to build 1.5.0 from source

John Jason Jordan johnxj at comcast.net
Tue Jun 21 01:58:52 UTC 2011

On Tue, 21 Jun 2011 02:15:18 +0100
Michael Crane <mick.crane at gmail.com> dijo:


Thanks. That solved the problem.

However, the compile failed at the end:

 U   Scribus
Checked out revision 16685.
-- Shared Library Flags: 
-- The C compiler identification is GNU
-- The CXX compiler identification is unknown
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not
 found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or
 name. -- Scribus 1.5.0.svn will be built to install
 into /usr/local/scribus_svn -- Machine: x86_64-redhat-linux, void
 pointer size: 8 -- Found target X86 -- Found target X86_64
-- Building for target x86_64-redhat-linux
-- Using standard ApplicationDataDir. You can change it with
 at /usr/share/cmake/Modules/FindQt4.cmake:1225 (MESSAGE): Qt qmake not
 found! Call Stack (most recent call first):
  CMakeLists.txt:465 (FIND_PACKAGE)
-- Configuring incomplete, errors occurred!
make: *** No targets specified and no makefile found.  Stop.
sudo: make install: command not found

I also tried the commands from the wiki, and got similar errors at the
end, particularly the CMake Error line.

It appears I need to install a package or fix a config file or

More information about the scribus mailing list