[scribus] no odt support???

Rolf-Werner Eilert eilert-sprachen at t-online.de
Thu Jun 26 10:30:40 CEST 2008

Craig Bradney schrieb:
>> ----- Original Message -----
>> Subject: Re: [scribus] no odt support???
>> From: Rolf-Werner Eilert <eilert-sprachen at t-online.de>
>> To: cbradney at zipworld.com.au,"Scribus User Mailing List"
> <scribus at lists.scribus.net>
>> Date: 25-06-2008 8:40
>> Craig Bradney schrieb:
>>> Theres nothing wrong with the source that I can see...
>>> before you run configure, please run
>>> make -f Makefile.svn
>>> as per:
>>> http://docs.scribus.net/index.php?lang=en&page=install3
>>> I have just gone through and tested many scenarious of code, missing
> includes, 
>>> incorrect autohell versions etc, with the tarball and had all of the 
>>> mentioned issues. Running the make -f line fixed it in one go with no 
>>> workarounds.
>>> Craig
>> Even if it's not the svn version, Craig? I got the ordinary source of 
>> the stable to compile.
> Having not used autohell for awhile it took me awhile to go through the
> elimination process last night. I finally remembered we had issues like this
> in the past and it was because the person had not run make -f Makefile.svn.
> It will depend on your system as to whether you need this or not, I found I
> always had to run it in the past.
> Use cmake.. you hair wont go grey, and you wont be pulling it out at every
> call to configure. No nasty spells required either.
> Craig

Just tried "make -f Makefile.svn", but it didn't help either. Just fyi 
it said this

*** Creating acinclude.m4
*** Creating list of subdirectories
*** Creating configure.files
*** Creating configure.in
cat: ./admin/configure.in.bot.end: No such file or directory
*** Creating aclocal.m4
acinclude.m4:3270: the serial number must appear before any macro definition
acinclude.m4:3315: the serial number must appear before any macro definition
acinclude.m4:3360: the serial number must appear before any macro definition
acinclude.m4:5489: the serial number must appear before any macro definition
*** Creating configure
*** Creating config.h template
*** Creating Makefile templates
*** Postprocessing Makefile templates
*** Creating date/time stamp
*** Finished

then I did ./configure and "make -j" just like the first time. But still 
no odt-support.

Now I tried the same but with "make" because "-j" was the only deviation 
from all the other runs in the past.  But to no avail - it still has no 
odt support.

Well cmake - don't know if it's ready on my system and what to do with 
it, but I wouldn't mind using it :-)


More information about the scribus mailing list