[Scribus] 1.3.5 svn miseries

John Culleton john
Tue Feb 12 19:35:40 CET 2008

On Monday 11 February 2008 05:22:01 pm Craig Bradney wrote:
> On Tuesday 12 February 2008 03:44:00 John Culleton wrote:
> > I have two partitions, one Kubuntu unstable and one Slackware 12.
> > Currently neither one compiles 1.3.5 svn.
> >
> > Let me deal with the Slackware problems first, since the Kubuntu problems
> > seem to be associated with some wierdness in the gcc install. On slack 12
> > I get reassuring messages from cmake. In particular it finds Qt 4. But
> > from the following make I get 1,732 error messages.  Here are the first
> > few: /usr/local/trunk/Scribus/scribus/fonts/scfontmetrics.cpp:7:18:
> > error: QColor: No such file or directory
> > /usr/local/trunk/Scribus/scribus/fonts/scfontmetrics.cpp:8:16: error:
> > QMap: No such file or directory
> > /usr/local/trunk/Scribus/scribus/fonts/scfontmetrics.cpp:9:19: error:
> > QMatrix: No such file or directory
> > /usr/local/trunk/Scribus/scribus/fonts/scfontmetrics.cpp:10:20: error:
> > QPainter: No such file or directory
> > /usr/local/trunk/Scribus/scribus/fonts/scfontmetrics.cpp:11:19: error:
> > QPixmap: No such file or directory
> > /usr/local/trunk/Scribus/scribus/fonts/scfontmetrics.cpp:12:19: error:
> > QRegExp: No such file or directory
> > /usr/local/trunk/Scribus/scribus/fonts/scfontmetrics.cpp:13:23: error:
> > QStringList: No such file or directory
> >
> > My svn update is from today. I tried make clean but that didn't help.
> Something is not setting up your include system correctly... we have
> changed to the new include syntax per Qt4:
> Include Syntax
> The syntax for including Qt class definitions has become
>  #include <QClassName>
> For example:
>  #include <QString>
>  #include <QApplication>
>  #include <QSqlTableModel>
> This is guaranteed to work for any public Qt class. The old syntax,
>  #include <qclassname.h>
> still works, but we encourage you to switch to the new syntax.
> If you attempt to include a header file from a library that isn't linked
> against the application, this will result in a compile-time warning
> (e.g., "QSqlQuery: No such file or directory"). You can remedy to this
> problem either by removing the offending include or by specifying the
> missing library in the QT entry of your .pro file (see Build System above).
> I'm not sure what would cause that type of include to fail.. looks like its
> not including a core part. hmm
> Craig

Well I corrected one mistake. On svn I was asking for 13x when I should have 
been asking for 135x. And on the Kubuntu side I needed to install 
build-install also.  Slackware has all the compile requirements as  standard. 
Guess I am spoiled.

On Slack I noted that if I linked certain include files into my compile 
directory then errors went away. So I linked /usr/lib/Qt4-4.3.3/include 
to /usr/include/qt4. That solved many errors. 

I also had a problem with missing *qt* files in /usr/bin so I moved them also 
from another partition to /usr-bin. Now the compile proceeds.

The installation of qt4 etc. on my system had some missing or misplaced 
pieces.  At the moment I am up to 33% of make and things are coming along. 

Haven't tried to debug the Kubuntu install further. One copy will be enough 
for now. 

Life will be simpler when Qt4 matures enough to be included in Slack!

Thanks for all helpful comments.

John Culleton

More information about the scribus mailing list