[Scribus] Scribus 1.3.4 in Ubuntu amd64 repositories

John Jason Jordan johnxj
Tue Aug 7 21:00:44 CEST 2007

On Mon, 6 Aug 2007 08:23:59 -0400
"John R. Culleton" <john at wexfordpress.com> dijo:

> On Monday 06 August 2007, Craig Ringer wrote:
> > John R. Culleton wrote:
> > > On Monday 06 August 2007, Craig Ringer wrote:
> > >> There should be no need to build Scribus from source. You can if
> > >> you like, but it's probably nicer to use packages to do the job.
> > >
> > > One of the strengths of Linux is the ablility to go forward and
> > > backward thorugh versions of a package by downloading tarballs
> > > and copiling them.  Packaging systems just get in the way, as the
> > > instant case clearly illustrates.
> >
> > It depends on the user.
> In the instant case it depends on Ubuntu.  Ubuntu doesn't have the 
> stable version in its repository and therefore the user is stuck with 
> a mostly unusable unstable version.  Either he compiles from source 
> or does without Scribus.  

Today I finally solved the problem. 

I found an amd64 .deb of and downloaded it, thinking that maybe
it would not have the problems that 1.3.4 has. However, apt couldn't
find it in ~/Desktop where I downloaded the file to. I tried dpkg, but
it reported a long, scary list of unmet dependencies. I decided to try
to install it from Synaptic, where (hopefully) the dependency issues
would be resolved automatically. But Synaptic can't see your
filesystem, although it can see a CD. So I burned the .deb to a
CD, only to discover that Synaptic can't find my CD drive. (Grrr.
Actually, I remember this problem before, and have never figured out
how to fix it.)

Since I had Synaptic open I decided to poke around a bit. Scribus 1.3.4
was still listed as the only development version to install. But then I
remembered about "force version." I selected 1.3.4 and then on Package
> Force Version. A window popped up with a drop-down list - and there
was as an option. I proceeded to install, launched it,
and all is back to normal.

In order to install it Synaptic had to download it. So evidently is still in the repositories somewhere. It's just not in the
main list so you have to use the force version option. All that
googling trying to find the .deb of and it was right under my
nose the whole time.

More information about the scribus mailing list