[Scribus] PDF Error - Error (227233): Illegal digit in hex char in name

PLinnell mrdocs
Tue Nov 8 15:15:38 CET 2005

On Tuesday 08 November 2005 05:34, Calum Polwart wrote:
> For some time now I've been struggling with Scribus generated PDF's
> on a
> specific project I undertake.
> Other PDFs seem fine - just this one project.  I think I find the
> bug and all goes well for a few days only to get a new bug.  Some
> of the 'bugs' I find have been PNG Images, TIFF Images, SVG
> Graphics, Fonts - Especially the default font (Konochi I think it
> was) - which wasn't actually used anywhere but was listed in the
> Text Box as the font for the box, but then a style applied a proper
> font.
> I built a whole nex document from scratch test printing PDFs as I
> added new features and it worked fine till I added TIFF images -
> but I think there may be a whole issue with TIFFs on my machine as
> nothing will print them!  But then I start on the proper document
> and it all goes wrong.
> Anyway enough ranting.
> *Scribus Version - 1.3.1 (not CVS)
> Linux Version - Fedora Core 3 - on nightly Yum Update
> *
> Here's the interestign bit - Acrobat 7 opens the documents fine and
> they look fine on screen but usually will either fail to print
> altogether or fail after page 1.
> Acrobat 4 (god that was hard to find!!) opens and they look fine
> but printing puts squares in place of lots of characters.
> XPDF - opens and prints fine!!  However if I run xpdf from a
> command prompt it gives the following error message:
> Error (227227): Illegal digit in hex char in name
> Error (227233): Illegal digit in hex char in name
> etc etc...
> Every time you move page you create more of these...
> Anyone any thoughts?  Where should I begin debugging?  My guess
> would be that maybe the name of a frame or something (?based on an
> inserted file) is wrong/illegal - but how do i find it so that I
> know what to rename?
> PDF File is uplaoded to
> *http://www.wittongilbert.free-online.co.uk/banshee-liberty.pdf
> Any help appreciated...
> Ta
> *


I have had a look at this file. 

It prints fine from KPDF from 3.4.3 and Acrobat 5.0.5 under windows.

When I print from acroreader 7 linux, the very latest Ghostscript 8.53 
is choking on the generated PS from it. I have not tested on Acro 
reader 7.05 on windows. This not the first time I have seen this kind 
of error from Acro 7 however when printing to an inkjet printer which 
uses CUPS and pstoraster to convert the PS for the inkjet printer.

I doubt it is anything in the PDF itself. 

Acro reader 4.05 is horribly broken on Linux 5.0.10 has some bugs but 
printing is not one of them.

Hope that helps,

More information about the scribus mailing list