[Scribus] Re: Aqua versions crash on start #still #2

Martin b21280
Fri Jul 22 17:58:53 CEST 2005

Hello Andreas,

>If there's nothing following after that it means that Scribus hangs
>right at the start of searching for fonts.

So I thought as well, but I couldn't seem to find any fault with the 
font sets on the OS-X installations, on which I have tried to run it, 
and therefore...

>I'm afraid I've to ask

...no prob, I am more than happy to do some lower-level diagnossing 
of the issue!

>you to do the following:
>* type the following command in Terminal:
>	gdb  /Users/test/Applications/Scribus.app/Contents/bin/scribus
>* wait till gdb is finished starting up and shows the (gdb) prompt
>* type "run ENTER"
>* wait till Scribus is stuck in searching fonts
>* hit CTRL-C
>* type "where ENTER"
>* you can now stop Scribus with "CTRL-D ENTER y ENTER"
>* send the backtrace to me :-)

Here we go:
>Reading symbols for shared libraries ................ done
>(gdb) run
>Starting program: /Users/test/Applications/Scribus.app/Contents/bin/scribus
>Reading symbols for shared libraries 
>+++++++................................................... done
>Reading symbols for shared libraries . done
>scpaths: bundle at /Users/test/Applications/Scribus.app:
>scpaths: doc 
>scpaths: icon 
>scpaths: sample 
>scpaths: script 
>scpaths: template 
>scpaths: lib dir=/Users/test/Applications/Scribus.app/Contents/lib/scribus/
>scpaths: plugin 
>Reading symbols for shared libraries . done
>Reading symbols for shared libraries . done
>Reading symbols for shared libraries . done
>Reading symbols for shared libraries . done
>Reading symbols for shared libraries . done
>Reading symbols for shared libraries . done
>Program received signal SIGINT, Interrupt.
>0x054d5518 in tt_cmap12_char_index (cmap=0x0, char_code=40850) at 
>1772    /Developer/freetype-2.1.9/src/sfnt/ttcmap0.c: No such file 
>or directory.
>         in /Developer/freetype-2.1.9/src/sfnt/ttcmap0.c
>(gdb) where
>#0  0x054d5518 in tt_cmap12_char_index (cmap=0x0, char_code=40850) 
>at /Developer/freetype-2.1.9/src/sfnt/ttcmap0.c:1772
>#1  0x054aad00 in FT_Get_Char_Index (face=0x0, charcode=40850) at 
>#2  0x0034cd88 in FcFreeTypeCharSetAndSpacing () at scribusapp.h:24
>#3  0x0034c280 in FcFreeTypeQuery () at scribusapp.h:24
>#4  0x0034a888 in FcFileScan () at scribusapp.h:24
>#5  0x0034ac00 in FcDirScan () at scribusapp.h:24
>#6  0x00342b2c in FcConfigBuildFonts () at scribusapp.h:24
>#7  0x0034d380 in FcInitLoadConfigAndFonts () at scribusapp.h:24
>#8  0x0034d400 in FcInit () at scribusapp.h:24
>#9  0x00342c98 in FcConfigGetCurrent () at scribusapp.h:24
>#10 0x00350ccc in FcFontList () at scribusapp.h:24
>#11 0x001915c8 in SCFonts::AddFontconfigFonts() (this=0x68195d4) at 
>#12 0x00191b2c in SCFonts::GetFonts(QString, bool) (this=0x68195d4, 
>pf={static null = {static null = <same as static member of an 
>already seen type>, d = 0x61022d0, static shared_null = 0x61022d0}, 
>d = 0x614e800, static shared_null = 0x61022d0}, showFontInfo=true) 
>at scfonts.cpp:931
>#13 0x003138b8 in ScribusApp::GetAllFonts(bool) (this=0x6819200, 
>showFontInfo=true) at scribus.cpp:8328
>#14 0x002d4f80 in ScribusApp::initFonts(bool) (this=0x6819200, 
>showFontInfo=false) at scribus.cpp:407
>#15 0x002d3f68 in ScribusApp::initScribus(bool, bool, QString) 
>(this=0x6819200, showSplash=true, showFontInfo=false, 
>newGuiLanguage=Cannot access memory at address 0x800
>) at scribus.cpp:250
>#16 0x00327254 in ScribusQApp::init() (this=0xbffffcd0) at scribusapp.cpp:166
>#17 0x003285c8 in mainApp(int, char**) (argc=1, argv=0xbffffe48) at 
>#18 0x00328540 in main (argc=1, argv=0xbffffe48) at main.cpp:50
>Current language:  auto; currently c
>(gdb) The program is running.  Exit anyway? (y or n) y

Sooo, it's looking for the freetype package in Developers directory 
(or drive), no?
I decided to give it a whirl and copied the 2.19 version of FreeType 
into the developer directory on my startup drive, renamed it 
"freetype-2.1.9", and tried again to run it but then it gave me this 
on Ctrl-C:
>0x054f27e4 in tt_cmap12_char_index (cmap=0x0, char_code=151018) at 
>1984    /Developer/freetype-2.1.10/src/sfnt/ttcmap.c: No such file 
>or directory.
>         in /Developer/freetype-2.1.10/src/sfnt/ttcmap.c

And after creating a  "freetype-2.1.10" copy of FreeType 2.1.10 in 
Developers, it was still missing some Freetype ressources...

Well, it appears to me that there are some problematic references in 
the FreeType framework currently offered for download, at least in 
2.1.9 and in the 2.1.10 that comes inside the full frameworks package 
(haven't tried the separately available 2.1.10)
I wonder if other Aqua user can run the programm ok, because they 
have joined the Alpha testing party a bit earlier than me and may 
have kept older framework copies installed, just updating the main 

Looking forward to get this running... ;-) TNX! -Martin

More information about the scribus mailing list