[Scribus] Installation problems, Scribus 1.2.0 to RedHat 9

Craig Ringer craig
Tue Jul 5 06:32:12 CEST 2005

On Mon, 2005-07-04 at 21:22 -0700, Robert R. Di Giorgio wrote:
> I am unable to install Scribus 1.2.0 in Red Hat 9. I'm new to Red Hat, 
> but I used Scribus in Xandros Linux, which installed it automatically.

I wouldn't recommend that you use either Scribus 1.2.0 or Red Hat 9,
personally. Both are pretty old, and both have newer versions out with
*lots* of major improvements.

I'm using Fedora Core 4 quite happily - that's what Red Hat evolved
into. I also use Debian. Others here use many things, including SuSE,
Gentoo, Slackware, etc.

As for Scribus - we just released 1.2.2 . That might be a good one to
grab. However, I don't think it'll run on RH9 without some significant
coaxing (upgrading various libraries, mostly). There's more info in the
mailing list archives, including many repetitions of the "argh, not RH9"

> My computer has a Pentium 4, 512 MB, many Gs of unused hard drive.
> I downloaded scribus-1.2-0.fdr.1.2.i686.rpm in the directory /home/scribus.
> I ran "rpm -i scribus-1.2-0.fdr.1.2.i686.rpm" in terminal, in the 
> scribus directory.
> I got the messages:
>     Warning: scribus-1.2-0.fdr.1.2.i686.rpm: V3 DSA signature: NOKEY, 
> key ID 3ff87d98
>     error: Failed dependencies:
>        Ghostscript >= 0:7.07 is needed by scribus-1.2-0.fdr.1.2.
>        liblcms.so.1 is needed by scribus-1.2-0.fdr.1.2.
>        Shared-mime-info is needed by scribus-1.2-0.fdr.1.2.

That RPM is for Fedora. You might be able to get it to run on RH9 but it
won't do so out of the box and you might have to add packages from
Fedora which will in turn require other packages from Fedora and so on.

> I downloaded libcms --- tar.gz(?) from the net, unzipped it, tarred it, 
> installed it, and got:
>     /usr/local/lib/liblcms.so.1.0.14
>     /usr/local/lib/liblcms.so.1 (which is a link to the above)
>     /usr/local/lib/liblcms.so (ditto)
>     /home/bobdi/lcms-1.14/src/.libs/  the same 3 files above

Yep. RPM doesn't know about that, though.

> I downloaded ghostscript-8.15.tar.gz from the net, unzipped, tarred, 
> configured and installed it, and got:
>     /home/bobdi/GPL/current/ghostscript-8.15  and many other ghostscript 
> files.
> I don't know what to do about the shared-mime-info dependencies.

shared-mime-info lives at freedesktop.org .

> I ran "rpm -i scribus-1.2-0.fdr.1.2.i686.rpm" again and got all the same 
> error messages.

Yep. RPM doesn't know about the extra files you installed, as they
weren't installed using RPM to manage the installation. It doesn't have
any package metadata for them.

If you're going to compile your own libs, you'd need to compile Scribus
as well. This will require you to install a bunch of -dev RPMs . Again,
I'm pretty sure this has been discussed at more length here before, so
you might want to search the archives.

The short answer is "don't do it, man" - some pain can be saved by using
a more modern distro.

Craig Ringer

More information about the scribus mailing list