[Scribus] Another attempt at Solaris 10 Sparc install

Rainer Heilke rheilke
Sun Feb 13 16:43:16 CET 2005

Greetings, everyone.

I thought I would send an update regarding my inability to compile 
Scribus under Solaris 10.

I am now running the General Availability release of Solaris 10 (no 
longer Beta). I've got all of the dependencies installed, and using the 
GCC package from SunFreeWare.com, tried to compile Scribus. It failed at 
the exact same spot (and with the same error) it's always failed at. So, 
I pulled down GCC-3.4.2, and built it, first using the existing GCC 
3.3.2, and then using the bootstrap method (to try to ensure that the 
old GCC wasn't still influencing the compile). Well, same thing. It is 
always failing here:

make[6]: Entering directory 
if /bin/bash ../../../../libtool --silent --mode=compile --tag=CXX g++ 
-DHAVE_CONFIG_H -I. -I. -I../../../.. -I/usr/local/include/freetype2 
-I/usr/local/include -I/usr/include/libxml2 -I/usr/local/qt/include  
-I../../../../scribus -DDOCDIR=\"/usr/local/share/scribus/doc/\" 
-DPLUGINDIR=\"/usr/local/lib/scribus/plugins/\" -DQT_THREAD_SUPPORT  
-Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith 
-Wwrite-strings -O2 -fno-exceptions -fno-check-new -fno-common  -MT 
sxwim.lo -MD -MP -MF ".deps/sxwim.Tpo" -c -o sxwim.lo sxwim.cpp; \
then mv -f ".deps/sxwim.Tpo" ".deps/sxwim.Plo"; else rm -f 
".deps/sxwim.Tpo"; exit 1; fi
sxwim.cpp: In constructor `SxwIm::SxwIm(QString, gtWriter*, bool)':
sxwim.cpp:80: error: expected primary-expression before '*' token
sxwim.cpp:81: error: base operand of `->' is not a pointer
sxwim.cpp:82: error: base operand of `->' is not a pointer
sxwim.cpp:83: error: type `int' argument given to `delete', expected pointer
make[6]: *** [sxwim.lo] Error 1
make[6]: Leaving directory 
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory 
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory 
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/export/home/rheilke/Scribus/scribus/plugins'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/export/home/rheilke/Scribus/scribus'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export/home/rheilke/Scribus'
make: *** [all] Error 2

The only thing I can think of anymore, is to try the demo of Studio 10. 
The two problems with that are that I cannot afford to buy it after the 
trial period, and I don't know just how complex it will be to set up my 
environment well enough to use it cleanly (without any of my GNU tools 
negatively impacting the compiles). So, if anyone has any new ideas, 
they would be most welcome.


PS The CVS pulls still compile (consistently) well under Sun's 
SUSE-based JAVA Desktop System.

PPS Also, I did a tutorial on Scribus for the Edmonton Unix User Group, 
/usr/group/edmonton, this past week. I did a decent demo of a number of 
the features and tools over the course of a half-hour or more. Everyone 
was suitably impressed. Well done, everyone. I can't say thanks enough 
for this program.  :-)

More information about the scribus mailing list