[Scribus] Compiling Scribus on Sol10 continued

Gregory Pittman gpittman
Wed Feb 2 21:57:02 CET 2005

Rainer Heilke wrote:

> Rainer Heilke wrote:
>> Craig Ringer wrote:
>>> On Mon, 2005-01-31 at 19:19 -0700, Rainer Heilke wrote:
>>>> sxwim.cpp: In constructor `SxwIm::SxwIm(QString, gtWriter*, bool)':
>>>> sxwim.cpp:80: error: parse error before numeric constant
>>>> sxwim.cpp:81: error: base operand of `->' is not a pointer
>>>> sxwim.cpp:82: error: base operand of `->' is not a pointer
>>>> sxwim.cpp:83: error: type `int' argument given to `delete', 
>>>> expected pointer   
>>> Also, I note this in your previous post on the topic: "I tried tar'ing
>>> up the tree, copying it to the Solaris system, and building there, but
>>> it keeps failing.". Is there any chance you can do a clean checkout on
>>> the Solaris box, or 'make distclean', to see if that helps? I can't
>>> really imagine how, but ... well, it's worth a try.
>> The make failed at the exact same spot, same error.
> I've done a clean cvs on the Solaris system, and did the make -f 
> Makefile.cvs. This finished, but had an error part-way through. I'm 
> not sure, but this may help point to something (I'm trying a build 
> anyway). The error was:
> *** Creating aclocal.m4
> /usr/local/share/aclocal/wxwin.m4:36: warning: underquoted definition 
>  run info '(automake)Extending aclocal'
>  or see 
> http://sources.redhat.com/automake/automake.html#Extending%20aclocal
> /usr/local/share/aclocal/wxwin.m4:59: warning: underquoted definition 
> *** Creating configure
I would also say the same thing as Peter -- I get this message all the 
time on one of my machines and it doesn't affect the build at all.
This is not a failure.  I think it has something to do with the 
particular environment on your machine that aclocal is looking at and 
totally unrelated and unimportant to Scribus.


More information about the scribus mailing list