[Scribus] Compiling problems on Solaris SPARC

Rainer Heilke rheilke
Tue Jul 6 02:54:29 CEST 2004

Greetings, everyone.

I've been having a real bear of a time compiling Scribus on Solaris. My 
first problem was getting Qt (it wouldn't compile, giving me a pthread 
error that was reminiscent of another compiling problem I had related to 
using GCC rather than Sun's compiler), so I downloaded and installed the 
KDE packages from kde.org. However, this still doesn't work. I have 
added the Qt libraries to the system default using crle, all of the 
Qt-related environment variables are set, and I've explicitly told 
./configure where to look, but it keeps bombing out with the "Qt must be 
 >= 3.0.2" error.

Is the Qt from KDE not the developer version, perhaps? Is there some 
trick I've missed? I'm running Solaris 10 for SPARC (Software Express), 
but I was having the same issues under 9. I've hunted around, but I 
can't find anything further that I haven't already tried.

Any help would be greatly appreciated. Thanks. :-)

Rainer Heilke

More information about the scribus mailing list