[Scribus] Installation Issues with Scribus 1.1.4

Peter Linnell scribusdocs
Fri Jan 9 18:59:25 CET 2004

On Fri, 2004-01-09 at 12:12, Hugh Esco wrote:
> Hey folks:  
> Hope this is the right place for these questions.  

It is.
> Yesterday, I attempted to install Scribus 1.1.4 on a Debian Woody machine upgraded with the Testing version of the packages.  
> ./configure bombs out at:  
> checking for libz... configure: error: not found. Check your installation and look into config.log
> What does that mean and what do I need to do about it, please?  apt-get install didn't work for me.  Debian's packages database is still down and I don't know what package name I should be asking for to satisfy this libz dependency.  

> Other questions:  
> I have these libraries newly installed:  
> /usr/lib/libfreetype.so.6
> /usr/lib/libfreetype.so.6.3.5
> I'm currently running Scribus 1.0.1, which works fine, but crudely.  I have produced one document with it so far.  Personally I could have done a better job with OpenOffice, frankly -- if only because I'm more familiar with it.  But I certainly see the potential here and am eager to see what the new version can do for me.  
> hesco at biko:~$ gcc --version
> 2.95.4
> I'd be reluctant to upgrade gcc for fear of breaking other applications on this machine which provides production services to our Party.  Is it possible to have two versions of gcc running on the same machine?  How necessary is it to run the later versions of these?  
> Could I possible compile the application somehow on another machine and then port it over to this one?  
> hesco at biko:~$ which qt 
> I'm guessing this is actually a library and not an executable, though.  
> How would I test for the right one?  
> The following are installed.  
> Is this sufficient?  
> /usr/lib/libqt-mt.so.2
> /usr/lib/libqt-mt.so.2.3
> /usr/lib/libqt-mt.so.2.3.1
> /usr/lib/libqt-mt.so.3
> /usr/lib/libqt-mt.so.3.2
> /usr/lib/libqt-mt.so.3.2.1
> /usr/lib/libqt.so.2
> /usr/lib/libqt.so.2.3
> /usr/lib/libqt.so.2.3.1
> /usr/lib/libqthreads.so.9
> /usr/lib/libqthreads.so.9.0.0
> /usr/lib/libqtmcop.la
> /usr/lib/libqtmcop.so.0
> /usr/lib/libqtmcop.so.0.0.0
> hesco at biko:~$ which python
> /usr/bin/python
> hesco at biko:~$ which libart_lgpl
> hesco at biko:~$ su -
> Password:
> biko:~# apt-get install libart_lgpl
> Reading Package Lists... Done
> Building Dependency Tree... Done
> E: Couldn't find package libart_lgpl
> Don't know what to do about this here.  Any ideas?  
> biko:~# which gs
> /usr/bin/gs
> biko:~# gs --version
> 7.07

A tough dilemma. Scribus 1.1.2+ will not compile with gcc 2.9x. This
decision was made to enable using more modern and upto date coding,
which relies on gcc 3.x, preferably 3.2 or 3.3.

I am surprised, you can't install gcc 3.2 in parallel in Debian.
Parallel versions of gcc can be built and exist side by side. I know its
possible even on cygwin. Redhat has had this for a long time as well.

libart is the rendering canvas - a major part.

libz - is probably owning to a out of date binutils or autoconf

There is very detailed info on needed versions in the scribus
documentation on-line. Go to http://scribus.net  and look under

ping us on #scribus irc.freenode.net - nice friendly place to visit.


More information about the scribus mailing list