[Scribus] Installation Issues with Scribus 1.1.4

Craig Bradney cbradney
Fri Jan 9 18:19:37 CET 2004

Hi there

> Hope this is the right place for these questions.  

Couldnt be a better place! The other option is #scribus on

> Yesterday, I attempted to install Scribus 1.1.4 on a Debian Woody machine upgraded with the Testing version of the packages.  
> ./configure bombs out at:  
> checking for libz... configure: error: not found. Check your installation and look into config.log
> What does that mean and what do I need to do about it, please?  apt-get install didn't work for me.  Debian's packages database is still down and I don't know what package name I should be asking for to satisfy this libz dependency.  

Try under zlib.

> Other questions:  
> I have these libraries newly installed:  
> /usr/lib/libfreetype.so.6
> /usr/lib/libfreetype.so.6.3.5
> I'm currently running Scribus 1.0.1, which works fine, but crudely.  I have produced one document with it so far.  Personally I could have done a better job with OpenOffice, frankly -- if only because I'm more familiar with it.  But I certainly see the potential here and am eager to see what the new version can do for me.  
> hesco at biko:~$ gcc --version
> 2.95.4

For anything greater than Scribus 1.1.2, you will need gcc 3.0+.

> I'd be reluctant to upgrade gcc for fear of breaking other applications on this machine which provides production services to our Party.  Is it possible to have two versions of gcc running on the same machine?  How necessary is it to run the later versions of these?  


> Could I possible compile the application somehow on another machine and then port it over to this one?  

Even if so, you will still the need the libraries it is linking to.
> hesco at biko:~$ which qt 
> I'm guessing this is actually a library and not an executable, though.  
> How would I test for the right one?  
> The following are installed.  
> Is this sufficient?  
> /usr/lib/libqt-mt.so.2
> /usr/lib/libqt-mt.so.2.3
> /usr/lib/libqt-mt.so.2.3.1
> /usr/lib/libqt-mt.so.3
> /usr/lib/libqt-mt.so.3.2
> /usr/lib/libqt-mt.so.3.2.1
> /usr/lib/libqt.so.2
> /usr/lib/libqt.so.2.3
> /usr/lib/libqt.so.2.3.1
> /usr/lib/libqthreads.so.9
> /usr/lib/libqthreads.so.9.0.0
> /usr/lib/libqtmcop.la
> /usr/lib/libqtmcop.so.0
> /usr/lib/libqtmcop.so.0.0.0

As above, for any later version of Scribus, you will need Qt 3.x

> hesco at biko:~$ which python
> /usr/bin/python

For the python scripting plugin, you will need Python 2.1+

> hesco at biko:~$ which libart_lgpl
> hesco at biko:~$ su -
> Password:
> biko:~# apt-get install libart_lgpl
> Reading Package Lists... Done
> Building Dependency Tree... Done
> E: Couldn't find package libart_lgpl

You will need libart_gpl.
> Don't know what to do about this here.  Any ideas?  

Not really any other option than to try to work through the dependencies
and get them installed. Perhaps you have another machine of similar
configuration that you can work our what you need to upgrade to get all
things working safely on this machine.
> biko:~# which gs
> /usr/bin/gs
> biko:~# gs --version
> 7.07

Thats ok.. although AFPL ghostscript 8.1x would help out depending on
your targeted use of Scribus. No need to worry about upgrading that one
at this point though.

More information about the scribus mailing list