[Scribus] Adding fonts.

John Culleton john
Thu Dec 9 17:20:58 CET 2004

On Thursday 09 December 2004 11:13, BandiPat wrote:

> > Have you added fonts successfully? If so, where did you put them? And
> > what did you do next?
> >
> > Thanks for any help.
> ==================
> John,
> Again, I make no warranties this will work for you with the Slackware,
> but this is the usual procedure I go through to install extra fonts.
> Also, I agree with Peter, in that using the KDE control center to
> install fonts works nicely.  I prefer to do them manually myself.
> In installing extra fonts, I always make a new directory within:
> /usr/X11R6/lib/X11/fonts/
> That is the main font location for the system, so it just seems best to
> put it there, if I want system wide usage.  Once installed, you need to
> build a couple of files and get them ready for use by ghostscript.  As
> root, from a shell, I run:  /usr/bin/fonts-config --force
> That should build a fonts.cache-1 & fonts.scale file within the
> directory.  I am not sure if that is a common command or SuSE specific
> though.
> If everything is good so far, I then add the path to my new fonts in
> /etc/X11/XF86Config or xorg.conf, in the font path area.  I then restart
> the X server, not reboot, just the X server.  I know there are suppose
> to be ways to add the fonts while in KDE, but restarting the X server
> works best for me and it only takes a few seconds.  Here's the procedure:
> ctrl-alt-F1 (takes you to one of many terminal screens)
> login as root user
> type:  init 3  (stops X server)
> press enter key
> type:  init 5  (restarts X and allows login to your preferred GUI)
> Hopefully that will help a bit.  At least, maybe it will give you some
> things to look at though.
> regards,
> Patrick

In short I have found success and happiness. Basically I followed the above 
guides with modifications. 

I have a directory /usr/newfonts which holds the fonts from the Knoppix 3.6 
 I added some fonts from the TeX distro.
 I did fc-cache from within that directory. 
I fired up Scribus and did the  settings->fonts-> additional paths bit, adding 
the /usr/newfonts directory.

The fonts became available in Scribus. The new font path is persistent. I 
didn't have to add anything to xorg.conf and I didn't have to restart 

My previous failure with the /usr/share/fonts directory can be attributable to 
one of two possible things:
1. A subdirectory structure in /usr/share/fonts copied from TeX.
2. An indigestible font somewhere.

My new directory has no subdirectories, and I am adding fonts a handful at a 
time and running fc-cache, then testing  in Scribus. 

The fonts I am adding are Type 1. Scribus seems not to care if there is an afm 
file or not for a given font. 

Ultimately I will move the directory with the new fonts to something more 
standard. But for now it works. 

My thanks to all who replied. I just knew there was a trick to it :<)
John Culleton

Short list of publishing/marketing books:

More information about the scribus mailing list