[Scribus] Adding fonts.

John Culleton john
Thu Dec 9 12:06:17 CET 2004

On Thursday 09 December 2004 00:25, BandiPat wrote:
> John Culleton wrote:
> > I took a bunch of fonts and  dumped them into
> > /usr/share/fonts/default/Type1 on my Slackware system.  Then I ran
> > fc-cache . The fonts still don't show up in Scribus. What more do I need
> > to do?
> >
> >
> > ------------------------------------------------------------------------
> John,
> Don't know if this works the same on your Slackware, but did you perhaps
> restart the X server?  Anytime I make changes of this nature, I
> ctrl-alt-F1, login as root, init 3 and lastly init 5.  That should
> reload the X server and all fonts, if there are no problems.

Earlier I rebooted, which of course restarts the X server. 

Today I just changed the ownership of /usr/share/fonts to my user id, ran 
fc-cache again as a user, not as root, rebooted and still the same result. 

As part of the reboot process fc-cache is run yet again.

The fonts in question have two origins, Knoppix 3.6 and the latest TeX-Live 
distribution. I put them in /usr/share/cache because I didn't want to muck up
the X11 font libraries. 

The theory behind the fc-cache process is that all X11 apps can share the same 
fonts. On my system there are four sources listed in 
the  /etc/fonts/fonts.conf directory:


I chose /usr/share/fonts as the least destructive location. 

Have you added fonts successfully? If so, where did you put them? And what did 
you do next?

Thanks for any help.

John Culleton

More information about the scribus mailing list