[Scribus] Cannot find freetype2

Craig Ringer craig
Mon Aug 23 09:11:11 CEST 2004

On Sun, 2004-08-22 at 23:41, Martin Costabel wrote:

> I have to  export PATH=/sw/lib/freetype2/bin:$PATH
> before running configure (this seems normal),
> but then I have to patch configure so that instead of
> FREETYPE_CONFIG="" it has 
> FREETYPE_CONFIG="/sw/lib/freetype2/bin/freetype-config"
> and instead of
> LIBS="-lfreetype it has
> Without this help, configure never finds the right freetype2.

A naeive fix for this problem is provded by the patch to configure.in at
the end of this email. The problem appears to be that configure.in is
not set up to use pkg-config to find freetype as is normal, but prefers
to use a hardcoded list of paths. Installing freetype in the same prefix
as scribus should work fine with the existing configure.in, but if you
install it in a location that's no in any of the usual library locations
and not in Scribus's ./configure'd prefix or exec-prefix it won't find

The simplistic fix below simply searches the users's PATH for
freetype-config first. A better fix would try to use pkgconfig, and fall
back to using the PATH then hard coded paths.

It's going to be a while before I know if this has solved all the
issues, as even on my shiny dual Xeon Scribus still takes a while to
build. I can't seem to use '-j 4' (or '-j 2') reliably - it seems there
may be some dependencies in the build process that are not explicitly
spelled out by the makefile but work fine anyway if there's only one
make job running.

Anyway, here's the patch. I'll post a follow-up when I'm sure it's
solved the issue entirely (examining the generated configure and
config.log suggests that it has).
Craig Ringer

--- configure.in.orig   2004-08-23 14:59:30.000000000 +0800
+++ configure.in        2004-08-23 15:02:40.000000000 +0800
@@ -52,7 +52,7 @@

-AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, [AC_MSG_ERROR([Could not find libfreetype anywhere, check http://www.freetype.org/])], [${prefix}/bin ${exec_prefix}/bin /usr/local/bin /opt/local/bin /usr/bin /usr/X11/bin])
+AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, [AC_MSG_ERROR([Could not find libfreetype anywhere, check http://www.freetype.org/])], [${PATH} ${prefix}/bin ${exec_prefix}/bin /usr/local/bin /opt/local/bin /usr/bin /usr/X11/bin])

 if test -n "$FREETYPE_CONFIG"; then

More information about the scribus mailing list