[Scribus] Printing Troubles

Martin Costabel costabel
Mon Sep 29 08:07:16 CEST 2003

Sunil Joshi wrote:
> Hi Peter and Martin:
> Thanks for both your notes.  In FINK, it only shows FLTK-X11.  I assume 

I don't know what version of fink you have installed, but I see fltk-x11 
(as a virtual package), and either fltk-x11-43 or fltk-x11-42. All of 
these are at fltk version 1.1.4. But anyway, this is not the problem.

> it is either X11-42 or 43.  Well, i tried your suggestions, and that 
> didn't seem to help with installation of XPP.  So, I went ahead and 
> downladed FLTK-1.1.3 and compiled it myself.  Then I tried to compile 
> XPP-1.1, and as I mentioned before, I went as far as configure.  Past 
> that, when i tried to run make, here is what i get.
>> [JantarMantar:sjoshi/desktop/xpp-1.1] sjoshi# make
>> /usr/local/bin/fluid -c mainwindow.fl
>> c++ -DPACKAGE=\"xpp\" -DVERSION=\"1.1\" -DHAVE_LIBX11=1 
>> -I/usr/X11R6/include  -g -O2 -c mainwindow.cxx
>> In file included from mainwindow.h:10,
>>                  from mainwindow.cxx:3:
>> xpp.h:36:23: cups/cups.h: No such file or directory
>> xpp.h:37:22: cups/ipp.h: No such file or directory
>> xpp.h:38:27: cups/language.h: No such file or directory

If you go the fink route, you have to install the cups-dev package. Then 
you have to run make with the parameters I indicated in my previous 
message so that it finds the cups headers.

Of ourse, you can, as you did for fltk, do everything by hand that fink 
does for you automatically. In this case, download the cups sources and 
install the headers. The cups system in MacOSX comes with everything it 
needs for running, but not with the headers needed for compiling.

As I said before, you will have to do some serious porting work in order 
to make this run.


More information about the scribus mailing list