[Scribus] Re: Scribus Nachrichtensammlung, Band 5, Eintrag 43

Patrick magicpage91
Wed Jul 23 03:05:27 CEST 2003

On Tue, 22 Jul 2003 11:56:30 +0100
drymartini at gmx.de (Robbie Pickering) wrote:

> scribus-request at nashi.altmuehlnet.de wrote:
> >I tried to ./configure Scribus last night. It came up with checking
> >for Qt... configure: error: Qt (>= Qt 3.0.2) (headers and libraries)
> >not found. Please check your installation!
> >For more details about this problem, look at the end of config.log.
> >
> >I went and downloaded QT 3.1.1 but it says I already have that
> >package. Can anyone give me some help here?
> >
> Same thing happened to me. I "solved" it by using
> ./configure --with-qt-dir=/usr/share/qt3 (or wherever your qt is)
> I then had to make a symlink in $QTDIR/lib/libqt-mt.so pointing at the
> actual library which is called libqt-mt.so.3.1.1 or something similar.
> After that scribus configured and built without an error. I just
> haven't got round to using it yet ;)
> I don't know what is at fault here, the configure script or Qt for not
> creating that symlink in the first place.
> I'm running Debian on ppc.

Probably the easiest thing to do when starting your compiles is to do
the "export" commands before your configure.

Like this:
export QTDIR=/usr/share/qt3 (for Debian)
export QTDIR=/usr/lib/qt3 (for SuSE and most others)

You might also want to do your KDE the same, if running KDE.
export KDEDIR=/opt/kde3 (for SuSE)

Remember that only the shell/konsole you issue these commands in will
pass these directions.  If you open another konsole, you have to redo
them.  After doing these, everything should find your QT3 & KDE files
they need to compile.


          ---SuSE Linux v8.2 Pro---
        Registered Linux User #225206
    "Life's a garden, Dig It!"  --Joe Dirt

More information about the scribus mailing list