[Scribus] Scribus 0.9.9, a couple of problems (one segfault, one compile error)

Erik Inge Bolsø knan
Wed Apr 23 22:00:22 CEST 2003


I've just started testing Scribus, but decided to go straight for 0.9.9
anyway, confident that I could track down most problems. Alas.

Slackware Linux 9
gcc (GCC) 3.2.2
Qt Meta Object Compiler version 26 (Qt 3.1.2)

./configure; make; make install worked just fine.

I've encountered one segfault, easily reproducible:

 * create a text box
 * Get Text ... insert some text
 * double click in the text box to edit the contents
 * position the cursor at the front of the text box, then press and hold
the delete key - once all the text is gone, another delete keypress causes
a segfault.

#0  0x082032a0 in ScribusApp::keyPressEvent(QKeyEvent*) ()
#1  0x40347d2c in QWidget::event(QEvent*) () from
#2  0x403ef3a2 in QMainWindow::event(QEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#3  0x402b58c4 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#4  0x402b5457 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#5  0x4025d04c in QETWidget::translateKeyEvent(_XEvent const*, bool) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#6  0x40259042 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#7  0x4026e261 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/qt/lib/libqt-mt.so.3
#8  0x402c9766 in QEventLoop::enterLoop() () from
#9  0x402c9608 in QEventLoop::exec() () from /usr/lib/qt/lib/libqt-mt.so.3
#10 0x402b5af1 in QApplication::exec() () from
#11 0x0822159d in main ()
#12 0x409b6bb4 in __libc_start_main () from /lib/libc.so.6

Problem #2: when I tried to narrow the problem down further, and thus
enabled debugging with --enable-debug=yes or --enable-debug=full, I got
compile errors that I couldn't make sense of...

if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/include/freetype2
-I/usr/lib/qt-3.1.2/include -I/usr/X11R6/include  -DQT_THREAD_SUPPORT
-D_REENTRANT  -ansi -W -Wall -pedantic -Wshadow -Wpointer-arith
-Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -g
-O2  -g -O2 -MT hyphen.o -MD -MP -MF ".deps/hyphen.Tpo" \
          -c -o hyphen.o `test -f 'hyphen.c' || echo './'`hyphen.c; \
        then mv ".deps/hyphen.Tpo" ".deps/hyphen.Po"; \
        else rm -f ".deps/hyphen.Tpo"; exit 1; \
hyphen.c: In function `hnj_hyphen_load':
hyphen.c:336: parse error before '/' token
hyphen.c: In function `hnj_hyphen_hyphenate':
hyphen.c:423: parse error before '/' token
hyphen.c:424:34: missing terminating ' character
hyphen.c:424:34: warning: character constant too long
hyphen.c:473: parse error before '/' token
hyphen.c:426: label `try_next_letter' used but not defined
make[3]: *** [hyphen.o] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/knan/nedlastet/editor/scribus-0.9.9'
make: *** [all] Error 2

Any suggestions?

PS. Are there no way to enter text from Scribus itself? You must make
separate text files?

Erik I. Bols? | email: <knan at mo.himolde.no>
The UNIX philosophy basically involves giving you enough rope to
hang yourself.  And then a couple of feet more, just to be sure.

More information about the scribus mailing list