[scribus-dev] A slight modification of the manual

Gregory Pittman gpittman at iglou.com
Tue Nov 15 18:04:20 UTC 2016

On 11/15/2016 11:45 AM, Juraj Fedel wrote:
> On Sun, Nov 13, 2016 at 06:43:16PM -0500, Gregory Pittman wrote:
>> I did find a typo, where getImageName() was also referred to as
>> getImageFile() incorrectly, so that's been fixed as well.
> Actually right name for this function is getImageFile [this is how it is
> named currently in scribus module). The typo was was in doc string for
> this function in C source.
> I fixed this typo in attached patch also renamed internal C function,
> and changed function name in manual pages.
> I belive getImageFile is more accurate then getImageName as name of this
> function (and it is already named this way in python module - only
> docstring was wrong).

Yes, I see what you mean. I should have looked further, since I had used
the command in a script I wrote, swapimages.py, and clearly, trying to
use getImageName() doesn't work.

Perhaps an even less confusing name for the command would be
getImageFilename or getImageFileName, but it's mainly important to be
consistent, and trying not to break old scripts.

I couldn't remember how to apply a patch, so I made the changes manually
and committed.


More information about the scribus-dev mailing list