[scribus] LaTeX Render Frame error on export in 1.5.4 macOS

John K. Parejko parejkoj at gmail.com
Thu Dec 27 21:46:52 UTC 2018

Thank you, your instructions fixed the “Your Render Frame configuration seems to be invalid” problem I was having. I can now start scribus via the application, instead of having to run it from a terminal.

Has anyone tried to export to PDF from the bundle I made?



> On 27Dec 2018, at 13:20, Br. Samuel Springuel <rpspringuel at gmail.com> wrote:
> Where is xelatex installed?  GUI launched apps have very restricted PATH in macOS. If you can do something from the command line but not the GUI, then that might be the problem.  I've run into a similar problem myself with lualatex.  You can see the procedure I used to get around it here:
> http://gregorio-project.github.io/introduction-scribus.html
> ✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️✝️
> Br. Samuel, OSB (R. Padraic Springuel)
> St. Anselm’s Abbey 4501 South Dakota Ave, NE
> Washington, DC, 20017
> 202-269-2300
> (c) 202-853-7036
>> On Dec 27, 2018, at 1:52 PM, John K. Parejko <parejkoj at gmail.com> wrote:
>>> On 27Dec 2018, at 12:23, Gregory Pittman <gpittman at iglou.com> wrote:
>>>> On 12/27/18 12:01 PM, John K. Parejko wrote:
>>>> Yes, I can generate PDFs from LaTeX, using either pdflatex or xelatex. Scribus even seems to be able to do so itself: the Render frame preview appears to be built correctly within Scribus, showing the rendered LaTeX in place.
>>>> Is there a way to see the full the command that Scribus is running?
>>> Hi again John,
>>> You should be able to look in File > Preferences > External Tools and see the specific pdflatex command with any modifiers. Mine has 'LaTeX (Command: pdflatex --interaction nonstopmode)’
>> Yes, I’m aware of that: that’s how I changed it to use xelatex. But that can’t be the full command that scribus is running, since it’s generating the files in a temporary directory (latex normally produces all output in the current working directory).
>>> The "Object is a placed PDF" is not really an error, it's just a message.
>> It must be an error, since you have to click “Ignore Errors” to get to the PDF export window.
>>> When I made a simple render frame, then saved to PDF to the /tmp directory, there were 4 files generated. One was the plain text LaTeX document, with accompanying .aux and .log files, and then a PDF consisting only of the render frame results, and finally the final PDF which incorporates the placed PDF. Interestingly, when I tried this again but saved the final PDF to another directory, I couldn't find the other three.
>> I just created a trivial document with a render frame with some math in it, and it was able to export to PDF.
>>> Can you find this find this file /var/folders/1s/x4hsw5kj4pdbnlvfw75zzkv40000gq/T/scribus_temp_render_QUKzdK.pdf?
>> I just re-ran the export, and I can see and open the PDF file in /var/folders/… that scribus claims it “Failed to load”. I wonder if there’s a timing mismatch, where scribus is checking for the file before it is fully written to disk?
>> Another piece of data (useful or not) is that I cannot even place a render frame if I open the Scribus application directly; I get an error message that “Your Render Frame configuration seems to be invalid”, but it doesn’t tell me which part is invalid, and the latex configuration is fine. But I can place render frames from the commandline (by running `/Applications/Scribus.app/Contents/MacOS/Scribus`), which makes me think that macOS SIP might be the cause of at least one of these problems.
>> John
>>>>> On 27Dec 2018, at 07:52, Gregory Pittman <gpittman at iglou.com> wrote:
>>>>> On 12/27/18 4:06 AM, John K. Parejko wrote:
>>>>>> Hello,
>>>>>> I’m having trouble with Render frames on macOS (10.13.6). They preview ok in Scribus (1.5.4), but I cannot generate the PDF, getting an error like the following after clicking “save” on the PDF export window:
>>>>>> Cannot write the file: /Users/parejkoj/lsst/temp/AAS2019/poster/Parejko-AAS2019-jointcal-poster.pdf
>>>>>> Failed to load an image : /var/folders/1s/x4hsw5kj4pdbnlvfw75zzkv40000gq/T/scribus_temp_render_QUKzdK.pdf
>>>>>> The preflight checker also claims that the render frame “Object is a placed PDF”, which I guess the output is, but that seems misleading given the goal of the render frame.
>>>>>> I’ve put a “Collect for output” version of the scribus project here:
>>>>>> https://fiddlernet.net/temp/poster.tar.gz
>>>>>> My only guess is that it might be related to the System Integrity Protection (SIP) introduced in macOS 10.11. I get the error whether I start by opening Scribus via the App icon, or by running `/Applications/Scribus.app/Contents/MacOS/Scribus` from a terminal.
>>>>>> Any suggestions on how to handle this are welcome. The error message doesn’t provide much guidance.

More information about the scribus mailing list