[scribus] Trying to build scribus 1.5 on macos: fails to find suitable libcairo

Richard Sharman rsharman at pobox.com
Wed Sep 14 02:55:14 UTC 2016

On Sep 13, 2016, at 6:12 AM, William Bader <williambader at hotmail.com> wrote:
> Could you try doing a debug build so that the gdb backtrace shows line numbers?
> I think that you can do it by starting a clean build and adding -DCMAKE_BUILD_TYPE=Debug -DWANT_DEBUG=1 to the cmake command line.

Thanks.  I’ve copied the source, installed macports and using it installed the prerequisites listed in install4.html (including ciaro) but it keeps complaining that it can’t find libcairo.  This is odd because it is in /opt/local/lib where the other libraries that it did find are. 

I tried changing -DWANT_CAIRO=1 to -DWANT_CAIRO=0 -DWANT_QTARTHUR=1 as suggested in one of the doc files but even after removing the CMake* files from the build directory and reissuing the cake command it fails in the same way.  (I tried replacing the cairo package with cairo-devel but it made no difference.)

$ cat buildit6.sh
cmake ../scribus15  -DWANT_CAIRO=0 -DWANT_QTARTHUR=1 -DCMAKE_INSTALL_PREFIX:PATH=/Users/richardsharman/Applications/Scribus.App/Contents/ -DWANT_DEBUG=1 -DCMAKE_BUILD_TYPE=Debug 
$ sh buildit6.sh
-- Shared Library Flags: 
-- Scribus 1.5.3.svn will be built and installed into /Users/richardsharman/Applications/Scribus.App/Contents
-- Machine: x86_64-apple-darwin15.6.0, void pointer size: 8
-- Found target X86_64
-- Found OSX El Capitan Target: Apple, 64 bit, X86
-- Building for target x86_64-apple-darwin15.6.0
-- APPLEBUNDLE install prefix: /Users/richardsharman/Applications/Scribus.App/Contents
-- Using standard ApplicationDataDir. You can change it with -DAPPLICATION_DATA_DIR
Setting x86_64 Architecture for OSX Build/Bundle
-- x86_64 
-- ----- USE QT 5-----
-- ----- USE QT Widgets-----
-- ----- USE Qt5Gui -----
-- ----- USE QT 5 XML -----
-- ----- USE Qt5Network -----
-- ----- USE Qt5OpenGL -----
-- ----- USE Qt5LinguistTools -----
-- ----- USE Qt5Quick -----
-- ----- USE Qt5PrintSupport -----
-- Qt VERSION: 5.6.1
ZLIB Library Found OK
No OSG found, building without 3D Extension
JPEG Library Found OK
TIFF Library Found OK
Python Library Found OK
-- FreeType2 Library Found OK
-- Checking for one of the modules 'libcairo>=1.14.0;cairo>=1.14.0'
CMake Error at /opt/local/share/cmake-3.6/Modules/FindPkgConfig.cmake:646 (message):
  None of the required 'libcairo>=1.14.0;cairo>=1.14.0' found
Call Stack (most recent call first):
  cmake/modules/CAIROConfig.cmake:28 (pkg_search_module)
  CMakeLists.txt:738 (FIND_PACKAGE)

CMake Error at CMakeLists.txt:738 (FIND_PACKAGE):
  Found package configuration file:


  but it set CAIRO_FOUND to FALSE so package "CAIRO" is considered to be NOT

-- Configuring incomplete, errors occurred!
See also "/Users/richardsharman/scribus-source/from-svn/1.5.2/build/CMakeFiles/CMakeOutput.log".

$ port list cairo-devel
cairo-devel                    @1.15.2         graphics/cairo-devel

$ ls /opt/local/lib/lib{jpeg,cairo}*.{a,dylib}

Any ideas?

More information about the scribus mailing list