[scribus] Font size problem with pdf export of latex frame

daspostloch at googlemail.com daspostloch at googlemail.com
Mon Jun 10 09:12:31 UTC 2013

Hi Greg,

thanks a lot so far - i got a big step further with your missing
dependency hint, although it seems to have been podofo, not poppler.
Details/other comments below.

On 06/10/2013 02:58 AM, Gregory Pittman wrote:
> On 06/09/2013 02:01 PM, daspostloch at googlemail.com wrote:
>> Hi,
>> I have a problem with font sizes of/in latex frames when exporting
>> to a pdf. This is a very common task when creating posters for
>> scientific conferences, so I'd say a somewhat common use case for
>> scribus. In detail:
>> To reproduce: create a new empty document (say, portrait letter
>> size), insert a render frame (say, in the upper right quarter of
>> the document). The standard latex text ("Manual Your \LaTeX-frames
>> setup is working when you can read this text!".. ) appears in
>> surprisingly big letters (ca. 12 lines of text on a single
>> letter-sized sheed). However, when exporting to pdf, I get what
>> I'd expect when having an 11pt font in latex: the font size
>> decreases dramatically.
> I'm not seeing this.

despite me hopefully not having to resort to higher resolution now the
embedding seems to work:

can you / did you set the "external tools" resolution to 300 dpi from
72 in the scribus preferences? Could you retry with that? If you do,
please restart scribus after that setting, it seems to need that in
order to take effect. Also, use a new latex frame, not copy an "old"
one created from before the setting change.

>> Also, and possibly a 2nd issue, I would have liked to check "Embed
>> PDF & EPS files (EXPERIMENTAL)" in the pdf export dialog, but this
>> is greyed out for me - any idea why or how to resolve?
> I'm not seeing this either. Do you recall messages about things missing
> when you ran cmake to compile your 1.5? I think you need poppler for
> this function.

This was a very valuable hint, thanks - poppler was fine, but podofo
missing. After adding podofo, i now seem to be able to embed pdf/eps.
will do full-scale testing now and then ask my distro to add that
as an (opt) dependency.

>> I've tried exporting to different pdf versions, typing in different
>> preferences for resolutions in various dialog fields, etc., to no
>> avail. The only thing that worked is setting the resolution of
>> Latex render frames to 72 instead of 300 in Preferences-> external
>> tools (72 was the default, but I have always used 300 previously
>> when creating posters). This seemed to make the displayed and
>> pdf-exported sizes  more similar. However, if the render frames
>> cannot be embedded (see above, greyed-out checkmark), how will I get
>> the high resolution I need for printing, then? In any case, I think
>> there is at least one bug, as the displayed and exported font sizes
>> vary vastly when setting the latex render frame resolution to 300dpi
>> in Preferences-> external tools?
>> Since I had planned to print my poster tomorrow, I'll now experiment
>> with lower release versions of scribus since i've used the same
>> toolchain successfully in the past.. but preliminary tests seemed
>> to indicate that I cannot save a downwards-compatible variant of my
>> file to use in lower versions of scribus, which would mean i'm pretty
>> much screwed in the short run?
> Sort of...one workaround could be to save objects in the Scrapbook,
> which 1.5.0 shares with 1.4.2, so then you just paste into a new
> document in 1.4.2. If you don't have too many objects/pages, it might be
> worth it.

Also good to know, thanks.


More information about the scribus mailing list