[scribus] Font size problem with pdf export of latex frame

daspostloch at googlemail.com daspostloch at googlemail.com
Sun Jun 9 18:01:24 UTC 2013


I have a problem with font sizes of/in latex frames when exporting
to a pdf. This is a very common task when creating posters for
scientific conferences, so I'd say a somewhat common use case for
scribus. In detail:

To reproduce: create a new empty document (say, portrait letter
size), insert a render frame (say, in the upper right quarter of
the document). The standard latex text ("Manual Your \LaTeX-frames
setup is working when you can read this text!".. ) appears in
surprisingly big letters (ca. 12 lines of text on a single
letter-sized sheed). However, when exporting to pdf, I get what
I'd expect when having an 11pt font in latex: the font size
decreases dramatically.

Also, and possibly a 2nd issue, I would have liked to check "Embed
PDF & EPS files (EXPERIMENTAL)" in the pdf export dialog, but this
is greyed out for me - any idea why or how to resolve?

I've tried exporting to different pdf versions, typing in different
preferences for resolutions in various dialog fields, etc., to no
avail. The only thing that worked is setting the resolution of
Latex render frames to 72 instead of 300 in Preferences-> external
tools (72 was the default, but I have always used 300 previously
when creating posters). This seemed to make the displayed and
pdf-exported sizes  more similar. However, if the render frames
cannot be embedded (see above, greyed-out checkmark), how will I get
the high resolution I need for printing, then? In any case, I think
there is at least one bug, as the displayed and exported font sizes
vary vastly when setting the latex render frame resolution to 300dpi
in Preferences-> external tools?

Since I had planned to print my poster tomorrow, I'll now experiment
with lower release versions of scribus since i've used the same
toolchain successfully in the past.. but preliminary tests seemed
to indicate that I cannot save a downwards-compatible variant of my
file to use in lower versions of scribus, which would mean i'm pretty
much screwed in the short run?

Thanks for any hints and pointers! Version info below,

I am using:

Scribus Version 1.5.0.svn
27 May 2013
Build ID: C-C-T-F-C1.12.14-64bit
Using Ghostscript version 9.07

but had the same problem with a few-weeks-older svn checkout.

System is arch linux:

$ uname -a
Linux hostname 3.9.4-1-ARCH #1 SMP PREEMPT Sat May 25 16:14:55 CEST 2013 
x86_64 GNU/Linux

More information about the scribus mailing list