[scribus] Trouble getting text into frames; characters display as boxes

Bill Flanagan bill at flanaganphoto.com
Sun Aug 26 19:59:40 UTC 2012


Volunteered to prepare a mailer for a local museum.  Scribus 1.4.1 seems 
like the best tool on my OpenSuse Linux (11.4, 32-bit) machine with KDE 4.6.

No trouble inserting 9 images in image frames.  I like the "adjust image 
to frame feature."

Text is a problem.  Using default font settings the Story Editor doesn't 
respond to anything but spaces after assigning the default style.  The 
cursor stays in place when letter keys are pressed.  If a space is 
pressed, the cursor moves and changes from a font-height line to a 
shorter vertical line positioned as a superscript.  Double L-clicking on 
the frame moves the cursor inside the frame where it behaves similarly.

Tried several times to import text from a file, using file/import/Get 
text.  This sometimes worked, but the text displayed as a series of 
check boxes, one per character.  In direct edit, I could delete these 
symbols but could not enter new text, not even more boxes.

Went to File/Preferences/Fonts and unchecked the first entry, Adobe Pi 
Std Regular.  Now nothing displays, not even boxes.

Searched the archive and came up with only two related cases:
1.  Zooming in at least 200% enabled editing for one writer, but not for me.
2.  Possible problems with Qt, so I made sure I have the latest in the 
openSuse archive and added a few small packages that provide Qt links 
and connections.  Closed and reopened Scribus but behavior is unchanged.

There is only one paragraph style in Story Editor:  default. Applying 
that style did nothing, so I created a new style (Head1, with font 
'Century Schoolbook L' bold) and applied it by selecting from the left 
column in SE.  Suddenly I could enter text in the RH column of SE.  
Shouldn't the default style allow text entry?

However, the display on the main screen and print preview still shows 
each character as a check box.  The assigned font is checked "use" in 

There was almost nothing else from searching lists.scribus.info that 
seemed related to this problem.  I hope it's a goof by a first-time user.

Thanks for your attention.


More information about the scribus mailing list