[scribus] Idiot wants to build 1.5.0 from source

John Jason Jordan johnxj at comcast.net
Wed Jun 22 20:57:27 UTC 2011

On Wed, 22 Jun 2011 19:17:44 +0200
Craig Bradney <cbradney at scribus.info> dijo:

>On 6/22/11 7:15 PM, Craig Bradney wrote:
>>> OK, rebuild as jjj completed. These are the commands I used:
>>> mkdir ~/Software/Scribus/ mkdir ~/Software/Scribus/src/ mkdir 
>>> ~/Software/Scribus/src/scribus_svn sudo mkdir /usr/local/scribus_svn
>>>  cd ~/Software/Scribus/src/scribus_svn svn co 
>>> svn://scribus.net/trunk/Scribus cd ./Scribus cmake 
>>> -DCMAKE_INSTALL_PREFIX:PATH=/usr/local/scribus_svn make sudo make 
>>> install
>>> All commands executed without error messages.
>>> It still won't launch; same results as before. This is the only 
>>> clue:
>>> [jjj at Devil8 Scribus]$ cd /usr/local/scribus_svn/bin/ [jjj at Devil8 
>>> bin]$ ./scribus Segmentation fault (core dumped)

>> mkdir -p ~/Software/Scribus/trunk/install/
>> mkdir -p ~/Software/Scribus/trunk/build/
>> mkdir -p ~/Software/Scribus/trunk/src/
>> cd ~/Software/Scribus/trunk/src/
>> svn co svn://scribus.net/trunk/Scribus
>> cd ~/Software/Scribus/trunk/build/
>> cmake -DCMAKE_INSTALL_PREFIX:PATH=~/Software/Scribus/trunk/install
>> ~/Software/Scribus/trunk/src/Scribus
>> # note that will probably wrap but its 1 line
>> make install
>> Then run
>> ~/Software/Scribus/trunk/install/bin/scribus

>oh.. and no sudo, su - and no root.. just run it.

I ran all the above commands as jjj, no sudo, no root anywhere.

I had a problem with the cmake line until I figured out there had to
be a space where it wrapped. (Duh!) Then it all worked fine until the
last command:

[jjj at Devil8 build]$ ~/Software/Scribus/trunk/install/bin/scribus
Segmentation fault (core dumped)

I note that this is the same error as when I used the commands from the
wiki page. 

I didn't see any error messages when the svn and cmake lines were
running.  But something must be going wrong.

I attempted to run it from the above command, also by navigating to
the folder and running ./scribus, and by double clicking on the
executable in Nautilus. I have attached the last lines
from /var/log/messages relating to the launch attempts. Maybe they'll
give someone a clue.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: messages
Type: application/octet-stream
Size: 2308 bytes
Desc: not available
URL: <http://lists.scribus.net/pipermail/scribus/attachments/20110622/48c3a73a/attachment.obj>

More information about the scribus mailing list