[scribus] Idiot wants to build 1.5.0 from source

Owen rcook at pcug.org.au
Wed Jun 22 06:49:26 UTC 2011

On Tue, 21 Jun 2011 22:35:50 -0700
John Jason Jordan <johnxj at comcast.net> wrote:

> On Tue, 21 Jun 2011 18:09:18 +1000
> "Owen" <rcook at pcug.org.au> dijo:
> >> 	Library Flags: -- The CXX compiler identification is
> >> unknown CMake Error: your CXX compiler:
> >> "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set
> >> CMAKE_CXX_COMPILER to a valid compiler path or name.
> >
> >
> >Please use your yum install powers to install these two items (I
> >think)
> >
> >gcc-c++
> >gcc
> >
> >Come back with any other errors that might cause cmake to fail. Note,
> >if it says it is missing something, but cmake still finishes, all
> >that means is a feature won't be built. Don't worry about that at
> >this stage
> OK, it's been 24 hours, but now I'm back taking more stabs at this.
> I installed gcc-c++ and gcc. I wiped out the folder that the wiki
> instructions had me make, and started over from the beginning. To
> clarify, these are the instructions from the wiki for building 1.5.0:
> mkdir ~/src/
> mkdir ~/src/scribus_svn
> sudo mkdir /usr/local/scribus_svn
> cd ~/src/scribus_svn
> svn co svn://scribus.net/trunk/Scribus
> cd ./Scribus
> cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr/local/scribus_svn
> make
> sudo "make install"
> I started over again from the top, following the above instructions to
> the letter, except that I wanted the whole thing in
> ~/Software/Scribus, so I modified the paths in the above example.
> It all went well until the cmake line. Here are the results:
> [root at Devil8 Scribus]# cmake
> 	-DCMAKE_INSTALL_PREFIX:PATH=/usr/local/scribus_svn 
> -- Shared Library Flags: -- The C compiler identification is
> GNU -- The CXX compiler identification is GNU -- Check for working C
> compiler: /usr/bin/gcc -- Check for working C compiler: /usr/bin/gcc
> -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI
> info
> - done -- Check for working CXX compiler: /usr/bin/c++
> -- Check for working CXX compiler: /usr/bin/c++ -- works
> -- Detecting CXX compiler ABI info
> -- Detecting CXX compiler ABI info - done
> -- Scribus 1.5.0.svn will be built to install
> into /usr/local/scribus_svn -- Machine: x86_64-redhat-linux, void
> pointer size: 8 -- Found target X86
> -- Found target X86_64
> -- Building for target x86_64-redhat-linux
> -- Using standard ApplicationDataDir. You can change it with
> -DAPPLICATION_DATA_DIR -- Looking for Q_WS_X11
> -- Looking for Q_WS_X11 - found
> -- Looking for Q_WS_WIN
> -- Looking for Q_WS_WIN - not found.
> -- Looking for Q_WS_QWS
> -- Looking for Q_WS_QWS - not found.
> -- Looking for Q_WS_MAC
> -- Looking for Q_WS_MAC - not found.
> -- Found Qt-Version 4.7.2 (using /usr/bin/qmake-qt4)
> Qt QTWEBKIT library not found.
> Qt4 Found OK
> CMake Error at CMakeLists.txt:473 (MESSAGE):
>   QtWebKit not found
> -- Configuring incomplete, errors occurred!
> So apparently QtWebKit was not installed. I tried installing it, but
> got a "no such package" error message. I tried appending -devel, and
> making it all lowercase with and without -devel, but the package was
> still not available. Finally, acting on a hunch, I opened Yumex and
> searched on "qt." This yielded qt-webkit-devel, which I installed.
> Afterwards the -DCMAKE line executed without error. Note to cmake:
> Computers are literal: Give me the correct name of the package.
> Then I ran the make command, which took forever and left my poor
> little computer overheated and out of breath. I noted several error
> messages like:
> /usr/include/QtCore/qbytearray.h: In member function ‘void
> ScImgDataLoader_PS::decodeA85(QByteArray&,
> QString)’: /usr/include/QtCore/qbytearray.h:452:11: warning: assuming
> signed overflow does not occur when assuming that (X - c) > X is
> always false 
> But I ignored them. Then I ran the "make install" command, but it
> turns out the command is not supposed to have the quotes as shown in
> the wki page instructions.
> Finally it all finished and I think 1.5.0 is installed. However, it
> did not create a launcher and I don't know the name of the
> executable, so I have no way to run it. From the command line
> "scribus" just launches 1.3.9. Does anyone know how to run my new
> Scribus?

Do a #yum search webkit

Should show something like

qt-webkit.i686 : Qt WebKit library
qt-webkit-devel.i686 : Development files for qt-webkit-devel

The install.

Don't wipe everything out once you have installed the webkit stuff,
just run the cmake command again

I notice you did the command as root. My advice would be not to do that.

But now that you have started, you will find build files with root:root
permissions. Suggestion, try as su, 
# chown -R devil8:devil8 ~/src/scribus_svn

(devil8 is your username?)

Can you get onto IRC, I could probably talk you through it that way.


More information about the scribus mailing list