[scribus] import text -> crash

Jan de Weerd jdweerd at ziggo.nl
Tue Feb 2 00:26:39 CET 2010

On 02/01/2010 11:29 PM, mrdocs wrote:
> On Monday 01 February 2010 14:20:04 Le Tigre wrote:
>> Le 31/01/2010 23:49, mrdocs a écrit :
>>> On Saturday 30 January 2010 20:18:08 Le Tigre wrote:
>>>> Hi everybody,
>>>> we are moving to but a bit disapointed.
>>>> Tryingo to import text (odt or html) in frame make Scribus crash, with
>>>> these messages:
>>>> - scribus: symbol lookup error:
>>>> /usr/lib/scribus/plugins//gettext//libodtimplugin.so: undefined symbol:
>>>> xmlSAXParseFile
>>>> or
>>>> - scribus: symbol lookup error:
>>>> /usr/lib/scribus/plugins//gettext//libhtmlim.so: undefined symbol:
>>>> htmlSAXParseFile
>>>> Same problem on two computers, both opensuse 11.2 and Scribus
>>>> via mrdocs on download.opensuse.org
>>>> It seems this is not a shared bug...
>>>> But I don't see what make the problem in my installation...
>>>> Regards
>>>> Raphael
>>> Hi,
>>> It appears Scribus is using some optional functions which are possibly
>>> not enabled in the default openSUSE libxml2 library. I am  testing
>>> rebuilding libxml2 to see if we can provide alternative packages and
>>> eventually enabled for openSUSE in the future.
>>> If my testing works, I will provide these packages in my repository.
>>> HTH,
>>> Peter
>> So I think it's not necessary I report a bug? It seems crash happens no
>> matter what file it is...
>> Waiting this new packages, we're using from MrDocs/OpenSuse 11.1
>> as Jan said.
>> Thanks
>> Raphael
> Hi,
> Please test the updated libxm2l packages here on a test or spare machine: 
> http://download.opensuse.org/repositories/home:/mrdocs:/branches:/devel:/libraries:/c_c++/
> I suspect this may fix the problem and if so, I can add these to be 
> automatically included in my repo.
> Thanks,
> Peter

Hi Peter,

I tried the above.
I also had to install libxml 2.7.6 instead of the installed libxml2.7.3
to be able to install the suggested file(s)
Then i reinstalled scribus from mrdocs opensuse11.2.
Started scribus from command line and opened a text window, right
clicked in it and selected get text from a test.odt file ..... scribus
crashed with following

scribus: symbol lookup error:
/usr/lib64/scribus/plugins//gettext//libodtimplugin.so: undefined
symbol: xmlSAXParseFile

So still no luck.

I'm going back to scribus from mrdocs opensuse 11.1


More information about the scribus mailing list