[scribus] Announcement: Scribus 1.3.9 released

Gerard Cunningham gerard at faduda.net
Sun Dec 5 13:50:32 CET 2010

On Sun, 2010-12-05 at 16:35 +1100, Owen wrote:
> > I tried one more tome, downloading the file described here and
> > following
> > the relevant instructions. I seem to have installed as a
> > result.
> >
> > Right now, I'm more than a little frustrated. What am I doing wrong?
> > Can
> > someone please post a set of clear, fool proof instructions to install
> > 1.3.9 on ubuntu 10.10, for clearly I am a fool.
> Hi,
> Step one can be done by using a browser. Steps 2 - 10 require a
> console, and if you are not familiar with that, then I can't help
>  1. Downloaded scribus-1.3.9 35 MBytes (scribus-1.3.9.tar.bz2 in my
> case. Normally Ubuntu puts this in your ~/Download directory)

Did this before. Did it again anyway. 
Obtained scribus-1.2.9.tar.bz2 from

>  2. $ sudo mkdir /scribus1.3.9   (this is where it will be installed)

Remember what I said about fool proof? Can you clarify for me, where do
I create that directory?
Is it:
1. /scribus-1.3.9
2. /home/scribus-1.3.9
3. /home/username/scribus-1.3.9
4. /home/username/Downloads/scribus-1.3.9

Maybe I was over thinking it , but lacking further clarity, I went with
option 1.

>  3. $ sudo chown username:username /scribus1.3.9 (replace username
> with your username, gerard?)

That's new. Did it.

>  4. If not already in your download directory, cd to it now

did that.

>  5. $ bzcat scribus-1.3.9.tar.bz2 | tar xv

the line command I used previously was 
tar -xvf scribus-1.3.9.tar.bz2

Ran your suggestion instead.

>  6. $ cd scribus-1.3.9

I was a bit stumped at this point. (I'm an idiot, remember?) All I've
effectively done is to unzip the file I downloaded. I note that created
a directory at

So now I have two scribus-1.3.9  directories.

Anyway, I changed directory to  /home/username/Downloads/scribus-1.3.9

>  7. $ cmake .  -DCMAKE_INSTALL_PREFIX:PATH=/scribus1.3.9 -DWANT_CAIRO=1

I get the following error:

CMake Error: The source directory "/scribus-1.3.9" does not appear to
contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.

So I moved to the top level directory /scribus-1.3.9 and tried the same
Same error.

Checked Google. No help. Or at least, none I can make sense of with my
limited non-programmer.

Until I resolve this error, there's no point in moving to step 8.

Any suggestions?

I should add that I've tried several times by now to install 1.3.9, and
there may well be all sorts of dross lying around on my hard drive.
Frankly, I'm ready to give up. Every time I write to the list, I have to
bite my tongue not to pepper my comments with Very Bad Words.

>  8. $ make
>  9. $ sudo make install
> 10. $ /scribus1.3.9/bin/scribus      will now start it for you
> /scribus1.3.9/bin/scribus
> All up, less than an hour, step 8 can take some time, say 30 or more
> minutes depending on your computer.
> Do step 3
> step 7. Note the . <---period/full stop after the cmake
> step 9 sudo can be omitted, but it will bomb out on the last line of
> the install, but that doesn't affect step 10.
> Step 7. Read the output, it may give valuable clues and if you don't
> understand it, email it to the list, someone may be able to help.
> You may well be missing some libraries. Keep in contact. I just did
> the above on a 64 bit Ubuntu-10.10, Scribus opens in a flash, blink
> and you will miss it starting!

Gerard Cunningham
Kildare, Co Kildare

More information about the scribus mailing list