[scribus] Error on 1.5.0 configure.

John Culleton john at wexfordpress.com
Mon Aug 23 00:49:37 CEST 2010

On Saturday 21 August 2010 19:21:39 Owen wrote:
> >>> cmake version 2.6-patch 2 is the version I have and get/got the
> >>> same error as John
> >>
> >> Are you able to test with 2.8.x?
> Well looks like cmake 2.8.2 gets rid of the problem. Even seems to
> build faster.
> For John
> Download the latest cmake-2.8.2.tar.gz from
> http://www.cmake.org/cmake/resources/software.html
> Unpack it and cd to the cmake-2.8.2 directory
> run # ./bootstrap --prefix=/usr/local  (assumes your current cmake
> is /usr/bin/cmake
> # make
> # sudo make install
> then type # which cmake and see if /usr/local/bin/cmake is selected
> if so run your cmake command as normal, otherwise let the command
> be the full path, eg /usr/local/bin/cmake

I'll try that as time permits. I will only note that 1.5.0 worked with 
my existing cmake file up through the beginning days of August. It 
looks like code was added the Scribus files to solve a Win and/or BSD 
problem that rendered the cmake step inoperable using older cmake 
programs.  Fixing that patch would seem to me less labor overall than
making everyone update their cmake to render that single patch 

When I wrote programs eons ago I tried to make them as generic as 
possible. That included accommodating those who had older or otherwise 
limited compilers.
John Culleton
Wexford Press
"Create Book Covers with Scribus"
Printable E-book 38 pages $5.95

More information about the scribus mailing list