[scribus] Glyphs in a font not appearing

John Jason Jordan johnxj at comcast.net
Sun Jun 14 17:29:20 CEST 2009

On Sun, 14 Jun 2009 16:30:25 +0200
Craig Bradney <mrb at scribus.info> dijo:

> John Jason Jordan wrote:
> > On Fri, 12 Jun 2009 08:56:20 -0400
> > Gregory Pittman <gregp_ky at yahoo.com> dijo:
> >
> >   
> >> John Jason Jordan wrote:
> >>     
> >>> 1.3.5 Rc2, Jaunty x86_64
> >>>
> >>> Just now I tried to type U2205 U2192 in the Story Editor using the
> >>> Junicode font. The characters appeared fine in Story Editor, which is
> >>> set to display text with Junicode. They also appear fine in all other
> >>> applications. When I closed Story Editor and updated the text frame the
> >>> characters were gone. I tried to enter them directly in the text frame,
> >>> but they did not appear. Then I tried inserting them with Insert >
> >>> Glyph, but the Glyph palette did not display these characters.
> >>>
> >>> Why does Scribus not see characters that are clearly in the font?
> >>> Should I file a bug report? Can someone reproduce this? Am I crazy? OK,
> >>> forget the last question.
> >>>       
> >
> >   
> >> While your Story Editor font may contain these characters, apparently 
> >> the font for the frame does not.
> >>     
> >
> > It's the same font.
> >   
> Not necessarily.
> The font's missing glyphs may be copied from another font or auto
> generated for the GUI. Scribus will not do that.

I understand what is happening now.

I always knew that Scribus (like InDesign) will not display a glyph
that is not truly in the font. This is as it should be, since otherwise
problems can result when sending files out to be printed. However, I
think it is wrong for the Stoy Editor to grab a glyph from another
font. That is what confused me. I did not realize that the Story Editor
would lie to me. It should not and I should add a feature request that
this behavior be changed so that Story Editor displays only the glyphs
that are truly in the font.

More information about the scribus mailing list