[Scribus] Problems installing Scribus 1.3.4 on an Intel Mac using Fink

Thorsten Zörner mail
Thu May 31 23:50:19 CEST 2007

Dear list,

this is Thorsten from Duesseldorf, Germany.

I've just joined the list, although I've been using Scribus for a  
couple of years already.
And I use it about four times a year to design a 6-sided Flyer folded  
to Portait A6.
It works great for what I use it. I love it!
However I still have to bring a PDF to a designer friend to transform  
it to a JPG in CYMK for offset printing.
So I am quite eager to see the improvements on color management, that  
1.3.4 is being advertised to have.

I work on a MacBook Pro, 2 GHz Intel Core Duo, running MacOS 10.4.9.  
and Fink 0.27.1.
So far everything worked great, but with only stable tree and  
1.3.4 unstable tree,
the built fails. Here is the protocol of the compilation


Banana-9:~ thorsten$ fink install scribus
Information about 2323 packages read in 0 seconds.
The following package will be installed or updated:
Setting runtime build-lock...
dpkg-deb -b /sw/src/fink.build/root-fink-buildlock- 
scribus- /sw/src/fink.build
dpkg-deb: building package `fink-buildlock-scribus-' in `/ 
Installing build-lock package...
/sw/bin/dpkg-lockwait -i /sw/src/fink.build/fink-buildlock- 
Selecting previously deselected package fink-buildlock- 
(Reading database ... 45321 files and directories currently installed.)
Unpacking fink-buildlock-scribus- (from .../fink- 
buildlock-scribus- ...
Setting up fink-buildlock-scribus- (2007.05.31-23.30.50) ...
bzip2 -dc /sw/src/scribus- | /sw/bin/tar -xf  
-  --no-same-owner --no-same-permissions
#!/bin/sh -ev
# Try to make cmake find Fink's freetype219. Needs quite some coaxing...
# Also don't build an app bundle in this version. We are using X11 here.
   perl -pi.bak -e 's|/usr/local/|/sw/lib/freetype219/|g' cmake/ 
   perl -pi.bak -e '
           s|libfreetype.so( FT.* )\"\"(.*)|libfreetype.dylib\1 \"/sw/ 
           s|(BUILD_MAC_BUNDLE) 1|\1 0|g;
                   ' CMakeLists.txt
#!/bin/sh -ev
export PATH=/sw/lib/freetype219/bin:$PATH
mkdir build
cd build
include \
libfreetype.dylib \
libpython2.5.dylib \
        -DPYTHON_INCLUDE_PATH:PATH=/sw/include/python2.5 \
libpython2.5.dylib \
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Check size of void*
-- Check size of void* - done
-- Check for working CXX compiler: /sw/var/lib/fink/path-prefix-g+ 
-- Check for working CXX compiler: /sw/var/lib/fink/path-prefix-g+ 
+-4.0/c++ -- works
-- Scribus will be built to install into /sw
-- Check if the system is big endian
-- Check if the system is big endian - little endian
CMake Error: No Qt3
-- Configuring done
### execution of /var/tmp/tmp.1.ldcSyU failed, exit code 255
Removing runtime build-lock...
Removing build-lock package...
/sw/bin/dpkg-lockwait -r fink-buildlock-scribus-
(Reading database ... 45322 files and directories currently installed.)
Removing fink-buildlock-scribus- ...
Failed: phase compiling: scribus- failed


Today I mailed back and forth with Martin Costabel, who replied very  
quickly and was very helpful.
He says, that the problem is, that I actually have the right qt3, but  
fink or CMake cannot find it.
Why this happens, he does not know yet.
Maybe some you guys have had the same problem and found a work around?

I tried to install scribus many times - same result.
I purged everything "qt3" from fink and re-installed it - same result.
I went to the stable tree - same result - and back to unstable - same  

Any help is greatly appreciated!


More information about the scribus mailing list