[Scribus] unexpected outcomes from CVS upgrades

Gregory Pittman gpittman
Sun Oct 17 17:20:02 CEST 2004

Probably some sloppiness on my part, but I recently (in the past several 
days) upgraded Scribus via CVS on a couple of the computers I have it on.
I normally don't do a 'make uninstall', just upgrade the cvs directory, 
'make -f Makefile.dist', yadayadayada...

On the first system (all running FC2), everything seemed to go OK, 
although I have to say the compile time was unexpectedly short.  After 
firing up Scribus I noted the version said somewhere back in mid-August(!).
On the second system, I decided to do a 'make clean' on the Scribus 
directory before cvs update.  When I ran 'cvs -z3 co Scribus' I got a 
LOT of messages about "need to move xxx out of the way"(?)  After 
compiling and installing, once again the version didn't change according 
to Help > About Scribus.
So today, on a third system, I renamed the old Scribus directory and in 
essence started from scratch.  This time it worked, and now I show a 
Build ID of 14.October...

Should I be doing a 'make uninstall' before each CVS update?  Starting 
from scratch seems to have been unnecessary in the past.

Greg Pittman

Addendum: I would suggest making a link from the CVS changelog page to 
the FAQ on Compiling from CVS.  I had forgotten the directory change for 
cvsroot and it took a while for me to find it.  Perhaps there could also 
be some links back-and-forth from the Scribus docs pages.

More information about the scribus mailing list