[Scribus] Compiling CVS with new SuSE 9.1 Prof. failed

BandiPat magicpage91
Mon May 3 05:31:06 CEST 2004

Sebastian R?der wrote:
> I but be happy if I know what`s the reason for my problem - I can not imagine 
> that it`s not possible anymore to compile progs with SuSE ;-) And in regard 
> of another post here in the list - in my opinion it`s not Novel, who causes 
> this problem - I think (or hope) that they will well support Linux and the 
> community, e.g. YaST is now unter the GPL. But because of a in my opinion 
> wrong release strategy, the release seems to be buggy (will be solved by 
> online updates after a certain time). I had some problems with Xfree and and 
> YaST which are mostly solved now - but I still don`t know why i can`t 
> compile. info '(automake)Extending aclocal' shows me the following:
> Starting with Automake 1.8, `aclocal' will warn about all
> underquoted calls to `AC_DEFUN'.  We realize this will annoy a lot of
> people, because `aclocal' was not so strict in the past and many third
> party macros are underquoted; and we have to apologize for this
> temporary inconvenience.  The reason we have to be stricter is that a
> future implementation of `aclocal' (*note Future of aclocal::) will
> have to temporary include all these third party `.m4' files, maybe
> several times, even those which are not actually needed.  Doing so
> should alleviate many problem of the current implementation, however it
> requires a stricter style from the macro authors.  Hopefully it is easy
> to revise the existing macros. 
> [snip...}


My info from a SuSE 9.1 beta tester is that the problem you found was 
older autotools files in Scribus.  I suppose Franz will update those 
soon, so the newer stuff will work.  As you might have found, SuSE 9.1 
ships with updated versions of autoconf and automake and it appears that 
Scribus isn't compatible yet.  The only other program he found to have a 
problem was MPlayer and they have already corrected that.  You mention 
that you haven't gotten anything to compile, which leads me to believe 
something is wrong in your setup as well.

Don't know if you are a beta tester or have compiled from source your 
SuSE 9.1, but it appears some programs will need to update for the new 
stuff now available.


           ---SuSE Linux v9.0 Pro---
         Registered Linux User #225206
     "Life's a garden, Dig It!"  --Joe Dirt

More information about the scribus mailing list