[Scribus] Scribus install problems on RH 7.3

andreas schalk andreasschalk
Mon Mar 31 13:44:29 CEST 2003

Es schrieb Johann Woelper:
> Hi list,
> i'm trying to install Scribus on RH 7.3 /QT 3.1.1. / gcc 2.96.
> configure and make runs without any error. After i execute the compiled binary, i get the message
> scribus: relocation error: scribus: undefined symbol: static_QUType_varptr

Maybe your problem is solved inbetween.
Some time ago i had a similar problem. 
This was the way, i solved it:

Just type on the console: 'ldd /usr/local/bin/scribus' (change the path
of the scribus binary according to your installation) and find out,
where scribus looks for the libqt-mt.so.3 file.

If in that path, where scribus looks for libqt-mt.so.3, is not a symlink
'libqt-mt.so.3', or this symlink does not point to your
libqt-mt.so.3.1.1, the relocation error message occurs.
Correct the symlinks, and everything will work (probably).

another case:
If you have updated Qt3 once or twice, the symlink 'qt3' in your
/usr/lib  may point to the rests of a previous installation (e.g. to the
folder '/usr/lib/qt3.0.5' but not to 'qt3.1.1').

Scribus strictly needs the Qt-version it is compilede with, not only

Hope that helps!

Andreas Schalk

More information about the scribus mailing list